lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-26-2015, 01:52 PM   #1
Phil949
Not Yet Wild
 
Join Date: Dec 2015
Posts: 2
Default Is it the speed sensor, the controller or the obc

My 2010 Precedent runs fine for about 10 holes on new fully charged batteries (at least I think they are fully charged they each measure 8.53 volts and the charger turns off). After about 10 holes when fully pressing the go peddle the cart cuts out ( seems like the power is cut off) then it goes very slowly then cuts out again. this jurky on-off motion keeps up until the cart just stops. I recharge the batteries and the cart runs just fine for another 10 holes and starts this all over again. This problem started after someone ran into my cart head on. The only damage was to the cowling. Any ideas?? how can I test these components?
Thanks:
Phil949 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-26-2015, 03:25 PM   #2
mrgolf
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,803
Default Re: Is it the speed sensor, the controller or the obc

What is battery voltage when it stops?
mrgolf is offline   Reply With Quote
Old 12-28-2015, 01:09 PM   #3
Phil949
Not Yet Wild
 
Join Date: Dec 2015
Posts: 2
Default Re: Is it the speed sensor, the controller or the obc

When it stops the voltage is 8.2 volts
Phil949 is offline   Reply With Quote
Old 12-28-2015, 01:22 PM   #4
Sergio
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 8,302
Default Re: Is it the speed sensor, the controller or the obc

Did You measure each individual battery after playing 10 holes when the cart is not working?

The impact from the collision could have damaged a battery cell, which may not be obvious after a charge, but would be exposed on a discharged condition.
Sergio is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
speed sensor, controller or both? Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Alltrax controller needing speed sensor? Electric EZGO
Does the speed sensor affect reverse speed? Electric Club Car


All times are GMT -5. The time now is 01:02 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.