lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-08-2007, 04:01 PM   #1
Kenneth S
Not Yet Wild
 
Kenneth S's Avatar
Yamaha
 
Join Date: Feb 2007
Location: San Antonio, Tx
Posts: 40
Default 2 cylinder ez-go

Got a friend who has a stock ez-go with the 2 cylinder engine and the engine does two things, one it burns oil out the exhaust (not all the time), two it makes it's own oil, the oil level goes above the full mark and smells like gas. I heard there were some kind of problems with these engines can anyone fill me in?
Kenneth S is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-08-2007, 04:06 PM   #2
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 26,543
Default

I'm not too familar with the Ezgo's but this type of thing on a Yamaha is usually due to a float problem in the carb. and allowing gas to dump over into the crankcase: trash in bowl of carb and making it overflow so to speak. See if there is oil/gas in the air breather, possibly coming out of the crank case vent.
spriddle is offline   Reply With Quote
Old 06-08-2007, 04:11 PM   #3
NO NO NO E-Z-GO!
Gone Wild
 
Join Date: Dec 2006
Location: ComplainAboutNoNo'sProfile-Ville
Posts: 4,995
Default

Check the valve seals and the compression. The rings may be so far gone it's doing that, or like James said, the carburetor is dead or needs a major makeover.
NO NO NO E-Z-GO! is offline   Reply With Quote
Old 06-08-2007, 04:22 PM   #4
Kenneth S
Not Yet Wild
 
Kenneth S's Avatar
Yamaha
 
Join Date: Feb 2007
Location: San Antonio, Tx
Posts: 40
Default

What's wierd is that when it smokes it's like a 2 stroke with the wrong oil-gas ratio, then it will just clear up and run clean. the cart never has hard time time starting no matter when, usually when a engine floods it runs bad or is hard to start but it allways runs the same and starts the same and it doesn't matter if carts cold or hot.
Kenneth S is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 03:42 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.