lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-22-2012, 06:34 PM   #1
ewalton13
Not Yet Wild
 
Join Date: Oct 2011
Posts: 28
Default Star Car Issues

Hello,

I have a 2009 Star Car 48V Golf Cart. I am having an issue with the motor stopping when you go over the slightest bump. Take your foot off the accelorator and press again and the solenoid clicks and you take off again. Seems to happen every time you hit any sort of bump. Even a manhole cover when riding on the road.

With some research I had thought it might be the solenoid dropping out. I ordered a new one and just put it in and still having the same problem. (btw if anyone is looking for a solenoid for a similar cart I found a place to get one for $59 + shipping out of NJ. The dealer quoted me a price of over $200!!!! They are actually a distributor of Curtis/Albright components).

The controler is giving a fault code of:
5,5 MAIN DROPOUT Main contactor open. 1. Main contactor defective.

Not sure what to do at this point. Any advise would be appreciated.

Thanks,

Eric
ewalton13 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-22-2012, 06:42 PM   #2
sms-shop
Gone Wild
 
sms-shop's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Gastonia NC
Posts: 530
Default Re: Star Car Issues

Check all the wire connections.. You have one that is loose... back of switch,battery area,controller and so on make sure everything is good and clean and tight..
sms-shop is offline   Reply With Quote
Old 09-22-2012, 06:49 PM   #3
ewalton13
Not Yet Wild
 
Join Date: Oct 2011
Posts: 28
Default Re: Star Car Issues

Thanks for the reply!

I think I have checked everything already. I had to pretty much remove everything around the controler just to get to the solenoid so I know everything around there is tightened up. I have also checked around the batteries and all seemed good. Only thing I may not have gotten a good look at is the actual connections at the motor since I couldn't really figure out how to get to it the way it's all configured. I'll take another look and make sure it's all tight.
ewalton13 is offline   Reply With Quote
Old 09-22-2012, 07:01 PM   #4
sms-shop
Gone Wild
 
sms-shop's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Gastonia NC
Posts: 530
Default Re: Star Car Issues

I would be looking at what activates the controller.... Like the key switch .....plug might be loose.. Under the floor board at the throttle(speed control)....
sms-shop is offline   Reply With Quote
Old 09-22-2012, 07:08 PM   #5
ewalton13
Not Yet Wild
 
Join Date: Oct 2011
Posts: 28
Default Re: Star Car Issues

Awesome, I'll check this out too. This problem just recently started. Most of the time this happens the motor just stops and the cart will just coast until I repress the accelorator. On a couple occasions it has stopped rather abruptly as if you have thrown it into reverse, though it doesn't back up. Guessing this happens maybe because everything quits and comes right back on without having to repress the accelorator. Thanks for the suggestions. I'll try to check it all out tomorrow and let you know the outcome.

Eric
ewalton13 is offline   Reply With Quote
Old 09-24-2012, 09:48 AM   #6
ewalton13
Not Yet Wild
 
Join Date: Oct 2011
Posts: 28
Default Re: Star Car Issues

I checked everything out and all connections are tight. Key switch seems good. I had thought maybe the keyswitch might be cutting off, but when the key switch is off all lights and everything turn off. Tested it last night and all power stayed on when the motor would cut off. I pulled out the speed control and opened it up. Everything looked to be good in there with no loose connections. While testing last night after checking everything at lower speed one time the cart hit a bump and stopped abrutly. I noticed that one of the rear wheels locked up and skidded a little as if the brakes were slammed or it was thrown into reverse, though I had not pressed the brakes.

Could there be an issue with the F/R controls possibly? There is just a switch on the dash, though I'm not sure what else controls this. It appeared that the wires going to the F/R switch are secure and I tested it for a while to make sure it was working properly. Any advise is appreciated.

Thanks,

Eric
ewalton13 is offline   Reply With Quote
Old 09-24-2012, 10:09 PM   #7
sms-shop
Gone Wild
 
sms-shop's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Gastonia NC
Posts: 530
Default Re: Star Car Issues

Can you tell what controller is in the cart ..? I'm thinking it is a Curtis 1268.
Does your cart have a parking brake...?
Does it have a seat switch...?
why I ask is after looking at the wireing schematic and the way you describe the problem it look like it could be the roll away circuit
sms-shop is offline   Reply With Quote
Old 09-25-2012, 08:21 AM   #8
ewalton13
Not Yet Wild
 
Join Date: Oct 2011
Posts: 28
Default Re: Star Car Issues

Yes, it is a Curtis 1268. There is a parking brake. If you are referring to the "RUN/TOW" switch under the seat then it does have that as well. Is there something you see that I could try or is it related to the controller itself?

Thanks again!
ewalton13 is offline   Reply With Quote
Old 10-07-2012, 04:23 PM   #9
ewalton13
Not Yet Wild
 
Join Date: Oct 2011
Posts: 28
Default Re: Star Car Issues

Does anyone have any additional thoughts in this issue? Still having problems.

Thanks!
ewalton13 is offline   Reply With Quote
Old 10-07-2012, 05:22 PM   #10
sms-shop
Gone Wild
 
sms-shop's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Gastonia NC
Posts: 530
Default Re: Star Car Issues

What was your finding on the roll a way circuit.... Was the switch working right....?
sms-shop is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
Possible battery issues or charger issues Columbia ParCar
powerdrive 2 issues and speed issues. Electric Club Car
New Star Star and Fairplay
Star Star and Fairplay
When you wish upon a star.... Golf Carts and Parts


All times are GMT -5. The time now is 07:58 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.