lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-03-2008, 04:18 PM   #1
RFC CART
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: ENNIS,TX
Posts: 21
Default Enigine Misses?

ONE CYLINDER IS MISSING I REPLACED THE PLUGG AND IT STILL HAS NO POWER. WHAT COULD BE WRONG?
RFC CART is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-04-2008, 08:54 AM   #2
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: Enigine Misses?

try adjusting the valves
ruredy is offline   Reply With Quote
Old 08-04-2008, 10:53 AM   #3
EZ-GOnewild
Gone Wild
E-Z-GO
 
Join Date: Apr 2008
Location: Wichita, KS
Posts: 1,520
Cool Re: Enigine Misses?

Ditto...
EZ-GOnewild is offline   Reply With Quote
Old 08-05-2008, 08:09 AM   #4
RFC CART
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: ENNIS,TX
Posts: 21
Default Re: Enigine Misses?

Ok I Will Try That,thanks
RFC CART is offline   Reply With Quote
Old 08-05-2008, 08:38 AM   #5
FlemmingDenmark
Not Yet Wild
 
FlemmingDenmark's Avatar
E-Z-GO
 
Join Date: Aug 2008
Location: Denmark
Posts: 43
Default Re: Enigine Misses?

If that doesn't work, check wirering. Pluggwire may also be faulty.

sorry about the spelling from denmark
FlemmingDenmark is offline   Reply With Quote
Old 08-05-2008, 11:24 AM   #6
EZ-GOnewild
Gone Wild
E-Z-GO
 
Join Date: Apr 2008
Location: Wichita, KS
Posts: 1,520
Cool Re: Enigine Misses?

Welcome Flemming! Great to hear from Denmark.
EZ-GOnewild is offline   Reply With Quote
Old 08-08-2008, 10:37 PM   #7
zarak
Not Yet Wild
 
zarak's Avatar
 
Join Date: May 2008
Posts: 63
Default Re: Enigine Misses?

Should also check the coils and the spark plugs...
zarak is offline   Reply With Quote
Old 08-15-2008, 03:53 PM   #8
RFC CART
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: ENNIS,TX
Posts: 21
Default Re: Enigine Misses?

Broken Piston
RFC CART is offline   Reply With Quote
Old 08-17-2008, 08:29 PM   #9
caddymankc
WILD
 
caddymankc's Avatar
E-Z-GO
 
Join Date: May 2007
Location: lebanon county,pa
Posts: 1,266
Default Re: Enigine Misses?

Is it a broke piston or a connecting rod? See if you put a screwdriver in the sparkplug hole and see if it moves up and down.If it dont then your broke the connecting rod, you might me able to save the engine its $60 for a connecting rod.
caddymankc is offline   Reply With Quote
Old 08-18-2008, 08:33 AM   #10
RFC CART
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: ENNIS,TX
Posts: 21
Default Re: Enigine Misses?

Thats Exactly What I Did And The Piston Did Not Move, How Much Labor Is In A Job Like That?
RFC CART is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 03:27 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.