lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-04-2012, 11:24 AM   #1
goldberg
Not Yet Wild
 
Join Date: Jan 2012
Posts: 14
Default selenoid clicks, no movement

Pack voltage after rest was 37.9. The selenoid clicks but the cart only makes a high pitch noise when the throttle is pressed, no movement in forward or reverse. This is a 36 volt cart.
goldberg is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-04-2012, 01:39 PM   #2
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,575
Default Re: selenoid clicks, no movement

Where is the noise coming from?
scottyb is offline   Reply With Quote
Old 07-04-2012, 01:57 PM   #3
goldberg
Not Yet Wild
 
Join Date: Jan 2012
Posts: 14
Default Re: selenoid clicks, no movement

Sounds like under the rear seat, near the motor, but I'm pretty certain the motor isn't turning.
goldberg is offline   Reply With Quote
Old 07-04-2012, 04:31 PM   #4
goldberg
Not Yet Wild
 
Join Date: Jan 2012
Posts: 14
Default Re: selenoid clicks, no movement

Ok getting frustrated. I found one cable that was damaged so I replaced it. It was the cable from the positive side of the battery pack to the solenoid, now the solenoid doesn't even click anymore. It is a 70-120224-2, so I will replace it and start over on my troubleshooting.
goldberg is offline   Reply With Quote
Old 07-04-2012, 04:49 PM   #5
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,575
Default Re: selenoid clicks, no movement

It sounds like you have a TXT series cart?
Does this chart match your cart...

What year & what drive system do you have?
The year is the last 2 digits of the manufacture code.... Just because the solenoid does not click does not mean it is bad or that a new one will click when installed in place of the old. Here is the solenoid activation diagram for a series cart
Attached Images
File Type: jpg ezgo-guide-#2.jpg (144.6 KB, 0 views)
File Type: jpg Ezgo PDS solenoid activation diagram.jpg (142.4 KB, 0 views)
scottyb is offline   Reply With Quote
Old 07-05-2012, 10:25 AM   #6
goldberg
Not Yet Wild
 
Join Date: Jan 2012
Posts: 14
Default Re: selenoid clicks, no movement

Thanks Scotty. by the looks of your chart i have a DCS cart and the last two digits of the manufacturer code are 99. i will try to trace out the wiring diagram this afternoon when i get off work to make sure everything looks right. if it helps diagnose the problem any, my problem originally started when first taking off after moving under power for 5' or so the cart would die but after a good whack right on top of the passenger side of the seat with my fist the cart would take off and run fine.
goldberg is offline   Reply With Quote
Old 07-05-2012, 10:33 AM   #7
camaroluvz28
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 934
Default Re: selenoid clicks, no movement

Did you have the run/tow switch in tow when you changed that bad cable? Usually when your able to whack or hit the cart somewhere and cart will move it points to bad solenoid...so you may be on the right track.
camaroluvz28 is offline   Reply With Quote
Old 07-05-2012, 10:37 AM   #8
goldberg
Not Yet Wild
 
Join Date: Jan 2012
Posts: 14
Default Re: selenoid clicks, no movement

yes i made sure to have it in tow when i was doodling...read
goldberg is offline   Reply With Quote
Old 07-05-2012, 10:38 AM   #9
goldberg
Not Yet Wild
 
Join Date: Jan 2012
Posts: 14
Default Re: selenoid clicks, no movement

yes i made sure to have it in tow when i was doodling...i'm some dumb but not plumb dumb
goldberg is offline   Reply With Quote
Old 07-05-2012, 10:39 AM   #10
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,575
Default Re: selenoid clicks, no movement

Quote:
Originally Posted by goldberg View Post
Thanks Scotty. by the looks of your chart i have a DCS cart and the last two digits of the manufacturer code are 99. i will try to trace out the wiring diagram this afternoon when i get off work to make sure everything looks right. if it helps diagnose the problem any, my problem originally started when first taking off after moving under power for 5' or so the cart would die but after a good whack right on top of the passenger side of the seat with my fist the cart would take off and run fine.
Okay, Fonzie!

Customer had a cart would not run until they banged the shift lever into gear several times, then away it went... they wanted a new F&R. I kicked the tire and the cart would go too. Turns out it had a very worn and loose spade connector on the solenoid activation circuit.
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
keeps burning up first selenoid Electric Club Car
Replace starter selenoid - generic ok? Gas EZGO
selenoid troble Electric Club Car
Pedal clicks but no movement Electric EZGO
96 CC 48V Solenoid clicks no movement - Newbie Electric Club Car


All times are GMT -5. The time now is 05:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.