lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-30-2011, 11:01 PM   #1
pjmia96
Gone Wild
 
pjmia96's Avatar
E-Z-GO
 
Join Date: Feb 2010
Posts: 547
Post Problem Fixed

Well I got this problem fixed.(For Now)
http://www.buggiesgonewild.com/elect...-problems.html


But I ran into another one,

You Know how when you get water on a solenoid and controller and the cart will have hesitation getting up to speed until the water dries? Well I wanted to remove gunk from my solenoid and controller so I sprayed brake and parts cleaner on the solenoids contacts and the controllers contacts, And now my cart will slowly lurch forward if I barely press the pedal and if I floor it it barely moves and just vibrates. I think it does this because I got the solenoid and controller wet from brake and parts cleaner. So I took the Air compressor and sprayed the Brake cleaner off and put my cart on the charger and hopefully it will be dry in the morning and ready to ride.


Could brake and parts cleaner Hurt the Solenoid or Controller in any way?
This is the stuff-http://www.amazon.com/CRC-Brakleen-Brake-Parts-Cleaner/dp/B000LDR9HI


Thanks for the info,

Matt
pjmia96 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-31-2011, 08:18 AM   #2
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 16,813
Default Re: Problem Fixed

The symptoms you state might be a stripped hub.

Remove hubcaps and/or dust covers on rear wheels so Castle nuts on rear axles are visible.
Have someone watch to see if one of the Castle nut spins, but wheel doesn't.
If nut spins on either side, the cart act like you described.
JohnnieB is online now   Reply With Quote
Old 12-31-2011, 12:41 PM   #3
pjmia96
Gone Wild
 
pjmia96's Avatar
E-Z-GO
 
Join Date: Feb 2010
Posts: 547
Default Re: Problem Fixed

I will let you know if it runs tomorrow, i have to go to a family gathering.
pjmia96 is offline   Reply With Quote
Old 12-31-2011, 05:46 PM   #4
Coltf1991
Gone Wild
E-Z-GO
 
Join Date: Jul 2011
Location: Houston, TX
Posts: 2,901
Default Re: Problem Fixed

Wait???? Family comes before golf carts?

Learn something new everyday
Coltf1991 is offline   Reply With Quote
Old 12-31-2011, 06:04 PM   #5
wrongway
Gone Crazy
 
wrongway's Avatar
E-Z-GO
 
Join Date: Sep 2011
Location: Sweet Home Alabama
Posts: 432
Default Re: Problem Fixed

Quote:
Originally Posted by Coltf1991 View Post
Wait???? Family comes before golf carts?

Learn something new everyday


My wife took an extra shift at work tonight...now I can spend some quality time with my cart!
wrongway is offline   Reply With Quote
Old 12-31-2011, 10:05 PM   #6
pjmia96
Gone Wild
 
pjmia96's Avatar
E-Z-GO
 
Join Date: Feb 2010
Posts: 547
Default Re: Problem Fixed

Lmao
pjmia96 is offline   Reply With Quote
Old 12-31-2011, 10:15 PM   #7
pjmia96
Gone Wild
 
pjmia96's Avatar
E-Z-GO
 
Join Date: Feb 2010
Posts: 547
Default Re: Problem Fixed

Ok, I think I have a bad battery. I am going to replace it tomorrow and see what happens. The wheels are fine. I will replace the battery and report back tomorrow.... This whole deal is going to make my brain corrode.
pjmia96 is offline   Reply With Quote
Old 01-01-2012, 08:56 AM   #8
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 16,813
Default Re: Problem Fixed

Quote:
Originally Posted by pjmia96 View Post
...............This whole deal is going to make my brain corrode.
A tinfoil hat prevents that from happening, but it has to be real tin, not the inferior aluminum stuff the younger generations promote.

JohnnieB is online now   Reply With Quote
Old 01-01-2012, 09:59 AM   #9
pjmia96
Gone Wild
 
pjmia96's Avatar
E-Z-GO
 
Join Date: Feb 2010
Posts: 547
Default Re: Problem Fixed

I'm ready for my front end alignment. I'm heading outside to look at the cart now I am going to test all batteries and replace the bad one. I should write the results in a few hours.
pjmia96 is offline   Reply With Quote
Old 01-01-2012, 09:59 AM   #10
pjmia96
Gone Wild
 
pjmia96's Avatar
E-Z-GO
 
Join Date: Feb 2010
Posts: 547
Default Re: Problem Fixed

Thanks for the Support
pjmia96 is offline   Reply With Quote
Reply

Tags
1999 txt ezgo, electric, ezgo, ezgo txt, txt
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
I thought I had My Family's charging problem Fixed Electric EZGO
Thank you guys! Choke problem fixed! Gas Yamaha
I think I fixed it Electric EZGO


All times are GMT -5. The time now is 01:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.