lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-21-2008, 07:43 PM   #1
sofar-sogood
Not Yet Wild
 
sofar-sogood's Avatar
E-Z-GO
 
Join Date: Feb 2008
Location: West Palm Beach, Fla
Posts: 65
Default G16 Running rough

Hello all, I just switched from an elec Yam to a G16. It starts slow and takes a lot of choke for a couple on minutes until it will run with out choke. When its running, it accelerates fine and smoothly but runs very rough at W.O.T. on the rpm limiter or at ant intermediate speed. Ive cleaned the foam air filter and replaced the paper filter as well as the spark plug with no improvement. Seems like a carb issue????? Whats my next step pls...
sofar-sogood is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-21-2008, 08:16 PM   #2
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 26,354
Default Re: G16 Running rough

Sounds like an air leak. Pull the air box and check the spacer and gaskets between the carb. and intake.

spriddle is offline   Reply With Quote
Old 06-24-2008, 08:29 PM   #3
sofar-sogood
Not Yet Wild
 
sofar-sogood's Avatar
E-Z-GO
 
Join Date: Feb 2008
Location: West Palm Beach, Fla
Posts: 65
Default Re: G16 Running rough

I pulled the card and cleaned it, check the valve lash @ .004, Ok 150 PSI compression, Reinstalled the carb and ran it on jack stands with out the air box. After choking it for 30-40 sec it ran ok at WOT but if I backed off the throttle to 1/4 or so and tried to back to WOT it would sputter and die unless I choked it. Im sure there are no vacuum leaks...Does the air box need to be on to operate properly? Also noticed a lot of compressed air coming from the valve cover hose? Valves too tight? New carb needed?
sofar-sogood is offline   Reply With Quote
Old 06-24-2008, 09:28 PM   #4
craig tn
Gone Wild
 
craig tn's Avatar
Yamaha
 
Join Date: Jan 2008
Location: Covington, TN
Posts: 1,942
Default Re: G16 Running rough

Yamaha's are sensitive to too much air. Check what spriddle wrote above. If it is getting too much air most of the time it will run better if choked at WOT.
craig tn is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
85 g1 running good Gas Yamaha
carts running Electric EZGO
older g2 running help Gas Yamaha
18hp.Vanguard Idles Rough Big Block Talk!
My cart running Videos


All times are GMT -5. The time now is 09:55 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.