lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-26-2019, 10:28 AM   #1
Wasga
Not Yet Wild
 
Join Date: Jun 2017
Posts: 6
Default EzGo Workhorse only runs up to 1/2 throttle then boggs.

I have an EzGo workhorse with the robin eh35c engine. It will run fine at less than half throttle, but if you press more it will start to bog down. Let me tell you what i have done already. It has a new carburetor and is getting fuel from the fuel pump. I adjusted valves to specifications. (.004) I have done the HEI conversion, new coil and new pickup coil. I checked the timing belt to make sure it was in time. I have 175# compression on both cylinders. I am stumped with this thing. Does anyone have any input?
Wasga is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-26-2019, 11:36 AM   #2
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 1,240
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

I personally have never seen the HEI done on the 4-strokes. Maybe you could show us how you did it.
I would check both clutches to see if they are working correct. Jack it up and look at them to see. Watch the driven clutch close to make sure it is spreading out.
trig123 is offline   Reply With Quote
Old 11-26-2019, 12:42 PM   #3
Wasga
Not Yet Wild
 
Join Date: Jun 2017
Posts: 6
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

The clutches are working correctly. This is an engine problem. It acts like its losing spark or fuel when full throttle. The HEI was done from a sticky on this forum.
Wasga is offline   Reply With Quote
Old 11-26-2019, 01:10 PM   #4
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 1,240
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

Quote:
Originally Posted by Wasga View Post
The clutches are working correctly. This is an engine problem. It acts like its losing spark or fuel when full throttle. The HEI was done from a sticky on this forum.
Could you show me where on here it shows how to change the 4-strokes over to HEI ? I must have missed it
trig123 is offline   Reply With Quote
Old 11-26-2019, 01:17 PM   #5
Wasga
Not Yet Wild
 
Join Date: Jun 2017
Posts: 6
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

http://www.buggiesgonewild.com/gas-e...onversion.html
Wasga is offline   Reply With Quote
Old 11-26-2019, 01:23 PM   #6
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: West of Mayberry
Posts: 1,240
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

I have read where people have tried it. Just never went to the trouble of doing it. The ignitor on these carts have a rev limiter built in them so that would be eliminated if you did the change over ? Hard to help you on something I have never did so I will turn this over to someone who has.
trig123 is offline   Reply With Quote
Old 11-26-2019, 02:21 PM   #7
Wasga
Not Yet Wild
 
Join Date: Jun 2017
Posts: 6
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

I have pretty much come up with the conclusion that the HEI conversion does not work properly. It did give me spark when I didn't have any but when the pedal is pushed down all the way it doesn't supply enough spark. The aftermarket ignitor the customer bought is not producing any spark.
Wasga is offline   Reply With Quote
Old 12-01-2019, 10:11 PM   #8
dirtyyoda77
Gone Wild
 
dirtyyoda77's Avatar
E-Z-GO
 
Join Date: Feb 2010
Location: Citrus Springs, FL
Posts: 409
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

why don't you go back stock on everything instead of trying to figure out the other persons mess
dirtyyoda77 is offline   Reply With Quote
Old 12-01-2019, 11:55 PM   #9
CP241
its pudding time
 
CP241's Avatar
Club Car
 
Join Date: Apr 2018
Location: GA
Posts: 4,376
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

Quote:
Originally Posted by dirtyyoda77 View Post
why don't you go back stock on everything instead of trying to figure out the other persons mess
I'd have to agree here. First step of unf*****ing someone else's mess is to put everything back as stock as possible.
CP241 is offline   Reply With Quote
Old 12-02-2019, 10:52 AM   #10
Wasga
Not Yet Wild
 
Join Date: Jun 2017
Posts: 6
Default Re: EzGo Workhorse only runs up to 1/2 throttle then boggs.

Ok, so everyhting is back to stock with new parts. I get one spark when pedal is pressed and one when I let off. It does not run this way. I have run the power to the coil and ignitor directly to the battery and it changed nothing. It would at least run with the HEI.
Wasga is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
WTB ezgo engine cradle and rear end for workhorse Golf Carts and Parts
I need Engine craddle dimensions for ezgo workhorse 1200 Clone Engine Swaps
Workhorse Engine Problem Gas EZGO
EZGO Workhorse Honda V Twin engine swap Big Block Talk!


All times are GMT -5. The time now is 05:55 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.