lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-14-2019, 09:08 PM   #1
jancelet
Not Yet Wild
 
Join Date: Sep 2019
Posts: 8
Default 2006 Club Car Precedent Turn/Brake Light Issue

Have 2006 with a Madgax Light Kit with Turn Signal and Horn. Horn works.

Issue is Passenger side Turn Signal (Front and Back) and Passenger Break Light.

BACK
Key and Lights OFF
Both Turn Signals WORK

Lights ON and Key OFF
Running Lights WORK
Brake Lights NO
Drivers Turn YES
Passenger Turn NO

Lights and Key ON
Running Lights WORK
Brake Lights DRIVER SIDE ONLY
Turn Signal DRIVER SIDE ONLY

Front turn signal PASSENGER side doesnt work but bulb does as i switched it with the other.

Any suggestions?
jancelet is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-15-2019, 10:20 AM   #2
WalterM6
Gone Wild
 
WalterM6's Avatar
Club Car
 
Join Date: Apr 2017
Posts: 1,506
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

Where are you getting your 12v's from?
WalterM6 is offline   Reply With Quote
Old 09-15-2019, 11:29 AM   #3
jancelet
Not Yet Wild
 
Join Date: Sep 2019
Posts: 8
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

It is the MADJAX MJTS1000 light system.

I have the 48 Volt CC system, the 12v is coming directly from the last battery #4 per the setup instructions. I installed this about 7 years ago.

Cant seem to figure out why when engaging the lights by pulling the light plug and thus turning on the front lights and running lights, that that somehow makes the Passenger Tail light no longer be able to show the Brake Light/Turn Signal, but the turn signal on Passenger Tail Light (and Driver Side Tail Lights) WORKS when KEY is OFF and LIGHTS are pulled out and on.

I dont think the Brake Timer Relay works for the Turn Signals, as they went on way past 1 minute.
jancelet is offline   Reply With Quote
Old 09-15-2019, 01:18 PM   #4
WalterM6
Gone Wild
 
WalterM6's Avatar
Club Car
 
Join Date: Apr 2017
Posts: 1,506
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

Did it ever work correctly?
WalterM6 is offline   Reply With Quote
Old 09-15-2019, 01:43 PM   #5
jancelet
Not Yet Wild
 
Join Date: Sep 2019
Posts: 8
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

I think so, but honestly dont really remember if I ever double checked it when it was installed and there are so few people here at the lake no one mentioned that it wasnt working properly, etc.

Just cant seem to grasp why when activating the light switch and thus turning on the front headlight and running lights, that that would someone stop the power to the passenger brake/turn signal light
jancelet is offline   Reply With Quote
Old 09-15-2019, 05:08 PM   #6
WalterM6
Gone Wild
 
WalterM6's Avatar
Club Car
 
Join Date: Apr 2017
Posts: 1,506
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

When a system has multiple problems it is usually a power supply problem. Do you think you could have got Bat #1 and Bat#4 switched and have the 12v supply connected to bat #1 instead of #4. If you can post a picture of your battery compartment.
WalterM6 is offline   Reply With Quote
Old 09-15-2019, 05:46 PM   #7
jancelet
Not Yet Wild
 
Join Date: Sep 2019
Posts: 8
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

Here it is, you can see it is #4 battery. Also, Passenger Tail Wires. Getting constant 6V on middle wire (yellow) with lights and Key OFF. When brake applied (with lights and key off) the break light comes on and then middle yellow wire jumps to like 7-8v. Again, both break lights and turn signals come on when KEY And LIGHTS are OFF. When KEY is ON and Lights OFF, both back turn signals work.

ONLY Driver side break and turn signal comes on when BOTH key AND lights are on.

Something is occurring when LIGHTS are ON, AND NOT at other times, that is stopping the brake and signal from WORKING.

The Madjax system has 2 yellow wires from the Lights ON switch
1) separates into 2 colors - does not join 2 lines, but rather is divided into 2 colors, right before 12 pin connector, BLUE (going to the Front HEADLIGHT) AND Brown going to 12 pin connector
2) splices into and joins BLUE that goes into the 12 pin connector

If you drive and engage the break, turn off LIGHTS but leave KEY ON, the break lights turn off after 30 seconds, but turn off LIGHTS and KEY to OFF break lights go off immediately
Attached Images
File Type: jpg 20190914_091221.jpg (144.1 KB, 0 views)
File Type: jpg 20190915_174004.jpg (373.9 KB, 0 views)
jancelet is offline   Reply With Quote
Old 09-17-2019, 02:33 PM   #8
jancelet
Not Yet Wild
 
Join Date: Sep 2019
Posts: 8
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

Right after the 12pin connector (dash going to back), with Running Lights ON, i get 2V on White (Drivers side back light) and 5V on Yellow (Passengers side back light), and when brake pedal is activated, Drivers side white goes to 12V BUT Passenger side yellow stays at 5V. Hence the problem.

So when Brake Pedal is ACTIVATED at what point is the new 12V splitting up into the YELLOW and WHITE Wires (since that must be the problem point)?

MADJAX says that I need a new LED Turn Signal Kit that the board in it is bad, yet the KIT i have was before they even made LED kits and the brake lights work on that side as long as you dont engage the light switch,
jancelet is offline   Reply With Quote
Old 09-18-2019, 06:33 PM   #9
fresnel151
Not Yet Wild
 
Join Date: May 2012
Location: Texas Gulf Coast
Posts: 8
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

I experienced years of strange and intermittent tail/turn/brake problems with an older light kit until I replaced both taillights. I eventually took apart the driver side tail light and found corrosion on the circuit board inside. No corrosion was seen inside the passenger tail light. I decided to gut and rebuild both tail light housings using two 4-inch LED flexible light strips for tail/turn/brake functions in each unit.

The refurbed lights worked great and ALL the issues disappeared. Maybe the tail light LED circuit board is what MadJax is referring to.
fresnel151 is offline   Reply With Quote
Old 09-19-2019, 07:58 PM   #10
jancelet
Not Yet Wild
 
Join Date: Sep 2019
Posts: 8
Default Re: 2006 Club Car Precedent Turn/Brake Light Issue

They gave me the number and it was for the LED Turn Signal, so there must be a board inside the Turn Signal that works for the Passenger Turn and Brake ONLY with Key ON and LIGHTS OFF. But the board malfunctions when LIGHTS are ON, and using Turn or Brake for Passenger Side Tail Light
jancelet is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Batteries issue/ 2006 club car precedent Electric Club Car
2013 Club Car Precedent with club car ultimate light kit brake lights not working Electric Club Car
06 Club Car Precedent light kit issue On Road Golf Carts!
Need brake light help for 2007 Club Car Precedent Electric Club Car
2006 gas club car precedent-motor won't turn over Gas Club Car


All times are GMT -5. The time now is 12:20 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.