lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-07-2017, 08:54 AM   #1
Samteryx
Not Yet Wild
 
Join Date: Aug 2017
Posts: 8
Default 97 CC 48v not running

I have a 97 48v that im having a time with,It will not run .I have 50v across the pack,load tested all batteries, key switch good,reverse buzzer working charger working,i hear a click from the accelerator switch.This model has the rocker switch and no tow/run switch it also has the controller with a 12 wire plug up into it.I bought the cart used and it has a neg feed wire to the solenoid on the pass side,that same solenoid has a jumper cable across the large terminals.This cart also has the large resister coil coming off the middle solenoid with green and white cables.Any ideas of what to check next?
Samteryx is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-07-2017, 09:16 AM   #2
Samteryx
Not Yet Wild
 
Join Date: Aug 2017
Posts: 8
Default Re: 97 CC 48v not running

I forgot to add that this cart has been great for 3 years no issues and the motor will run when jumped straight from the batteries.
Samteryx is offline   Reply With Quote
Old 08-07-2017, 05:44 PM   #3
NoleFan4Ever
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 15,283
Default Re: 97 CC 48v not running

That is a Regen 1 cart - Ouch!! To be sure, would need to see a pic of the controller. (At best it is still a regen 2)

They were notorious for controller issues (And a lot more!!)

Others can chime in on more ideas....
NoleFan4Ever is offline   Reply With Quote
Old 08-08-2017, 06:36 AM   #4
Samteryx
Not Yet Wild
 
Join Date: Aug 2017
Posts: 8
Default Re: 97 CC 48v not running

It has the t shaped controller gen 1 I suppose. I tried the yellow wire to ground and blue and white wires together. I tried white wire from controller to A2 on the motor and NOTHING.Whats my next step?
Samteryx is offline   Reply With Quote
Old 08-08-2017, 07:03 AM   #5
NoleFan4Ever
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 15,283
Default Re: 97 CC 48v not running

When you say a jumper cable across the large terminals are you referring to a precharge resistor or it is actually jumped with a heavy cable?

And have you been able to get the main solenoid/contactor to click or close in and pass current through it?

Pictures of all this would really help.
NoleFan4Ever is offline   Reply With Quote
Old 08-08-2017, 01:23 PM   #6
Samteryx
Not Yet Wild
 
Join Date: Aug 2017
Posts: 8
Default Re: 97 CC 48v not running

The solenoid has a heavy cable connecting the posts(basically bypassing it)
Samteryx is offline   Reply With Quote
Old 08-08-2017, 01:24 PM   #7
Samteryx
Not Yet Wild
 
Join Date: Aug 2017
Posts: 8
Default Re: 97 CC 48v not running

I don't hear any clicks and 48v+ is always running to the yellow cable
Samteryx is offline   Reply With Quote
Old 08-08-2017, 02:02 PM   #8
joesam
Gone Wild
Club Car
 
Join Date: Sep 2012
Location: Chestermere, Alberta - Canada
Posts: 1,146
Default Re: 97 CC 48v not running

On a Gen 1 controller (without a bypassed main solenoid), the controller powers-up the main solenoid and you would hear a distinct CLICK. If you remove that solenoid jumper, test the small gauge wires for 48v when you turn the key switch. If there is 48v when you turn the key - then a prior owner bypassed a failed solenoid (bad idea - it's a safety thing).

More likely there is no voltage on the small wires when you turn the key; and that tells you that your controller has already had a partial failure of one of it's primary functions.

The above statement assumes that the bypassed solenoid is the one WITHOUT the coiled wire resistor...correct?
joesam is offline   Reply With Quote
Old 08-08-2017, 02:33 PM   #9
NoleFan4Ever
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 15,283
Default Re: 97 CC 48v not running

Yeah, I think you are back to a controller issue as we first cited. Those are no longer made that I know of.....

There are upgrade kits out there to adapt it.
NoleFan4Ever is offline   Reply With Quote
Old 08-09-2017, 06:50 AM   #10
Samteryx
Not Yet Wild
 
Join Date: Aug 2017
Posts: 8
Default Re: 97 CC 48v not running

Yes the jumpered solenoid is the main one not the one going to the brake coil.
Samteryx is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2005 EZGO TXT motor not running and running jerky Electric EZGO
G2 Not running well Gas Yamaha
Foreseeable issues running a 36v cart, running at 48v? Harley Davidson
2010 EZGO not running/running very slowly Electric EZGO
Running Hot / Dieseling / Running on Gas Club Car


All times are GMT -5. The time now is 08:20 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.