lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-05-2017, 07:39 PM   #1
Jkirby891
Getting Wild
 
Join Date: Dec 2012
Posts: 99
Default New batteries no power at all to motor or reverse buzzer

Ok so I have a 2008 Club car precedent 48v cart. It was only running about 7 miles an hour when we got it. I decided to check the cables and noticed one looked as if the terminal was about to split. So I replaced the cable. Now I have no power to my cart. The reverse buzzer will not even sound.

I have by passed the obc and still nothing. I checked fused and replaced even though it was good.

I jumped solenoid and still nothing.

I have 48v at solenoid and key switch.

I checked all batteries 2 did not hold a full charge well so I replaced all four with Trojan t1260 brandnew still nothing. 50 v at pack.

Charger will not kick on now either.

Also please note I installed new tow switch and followed procedure once installing the new batteries and complete set of new cables. Problem still remains as it did before. No power to anything. However I get proper voltage at every point. Since the reverse speaker wont even power when r is selected on the switch I am led to believe controller failure.

I did not put in tow before replacing one of the battery cables. I did not see a tow switch. However later I went back and saw the previous owner removed the run tow switch cut the terminals and twist tied the two ends together in a wire nut. SO that being said. I mistakenly undid the power pack and put back with the cart in the run position.



Did I fry my controller? What else can I test.
Jkirby891 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-05-2017, 07:43 PM   #2
crash test dummy
Not Yet Wild
Club Car
 
Join Date: Nov 2011
Location: Z-HELLS FL
Posts: 0
Default Re: New batteries no power at all to motor or reverse buzzer

recheck your cables and wires ... i have forgotten 1 or 2
crash test dummy is offline   Reply With Quote
Old 04-05-2017, 07:52 PM   #3
Jkirby891
Getting Wild
 
Join Date: Dec 2012
Posts: 99
Default Re: New batteries no power at all to motor or reverse buzzer

Thanks for the reply. All cables are connected as they should be.

I also want to note that I tried jumping the neutral forward and reverse wires still nothing.
Jkirby891 is offline   Reply With Quote
Old 04-05-2017, 08:30 PM   #4
Jkirby891
Getting Wild
 
Join Date: Dec 2012
Posts: 99
Default Re: New batteries no power at all to motor or reverse buzzer

I haven't checked anything on the motor as of yet. anyone now where I should look next?
Jkirby891 is offline   Reply With Quote
Old 04-06-2017, 12:11 AM   #5
Golferdave
Gone Wild
 
Golferdave's Avatar
Club Car
 
Join Date: Dec 2016
Location: Alaska/SoCal
Posts: 549
Default Re: New batteries no power at all to motor or reverse buzzer

I'd focus on 1 thing at a time

Get the charging system working
If it worked before you started changing batts & cables
Could be a bad / loose / broken wire

OBC turns charger on
Should hear a click in charger when cart plugged in

Check charger, see if charger works on another cart

Lights work?
Golferdave is offline   Reply With Quote
Old 04-07-2017, 07:27 AM   #6
shaffer88
Gone Wild
 
Join Date: May 2013
Posts: 552
Default New batteries no power at all to motor or reverse buzzer

Does everything else work? Maybe you accidentally unplugged from micro switch

Edit: didn't read entire post sounds like bigger issue
shaffer88 is offline   Reply With Quote
Old 04-07-2017, 09:31 AM   #7
Jkirby891
Getting Wild
 
Join Date: Dec 2012
Posts: 99
Default Re: New batteries no power at all to motor or reverse buzzer

Golferdave

I do not have lights on this model. However nothing on it works it seems like everything has lost power. Charger was working before I disconnected one of the battery cables. now nothing works at all. I'm pretty sure the charger is good as it worked before. I am picking up another president today so I can try to change some parts. First I will try this charger on that cart. It has a pair of brand-new batteries installed and still nothing. since it's not charging and I have tried every other option I am assuming it is the controller is bad and it is not telling me everything to work.
Jkirby891 is offline   Reply With Quote
Old 04-07-2017, 09:42 AM   #8
Sergio
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 8,625
Default Re: New batteries no power at all to motor or reverse buzzer

A bad controller would still allow the cart to charge.

Are you sure none of the cables came unplugged from the Controller or OBC during the battery/cable change?
Sergio is offline   Reply With Quote
Old 04-07-2017, 12:16 PM   #9
Golferdave
Gone Wild
 
Golferdave's Avatar
Club Car
 
Join Date: Dec 2016
Location: Alaska/SoCal
Posts: 549
Default Re: New batteries no power at all to motor or reverse buzzer

IMO
You have a bad connection or a missing/broken/wrong location wire(s)
Follow wires from charger pug to batt + & batt -
Something in this area seems to be disconnected/broken

+ to Batt #1 + terminal
- to OBC then to B- on controller (which goes thru the OBC & is connected to Batt #6 -)

Check if you have pack voltage on the cart charger receptacle pins
Golferdave is offline   Reply With Quote
Old 04-08-2017, 06:36 PM   #10
Jkirby891
Getting Wild
 
Join Date: Dec 2012
Posts: 99
Default Re: New batteries no power at all to motor or reverse buzzer

I decided to unplug controller and plug back in once i did i regained power and cart is running again. However after battery and cable replacement cart only goes 7mph still. Decided to replace speed sensor but still no luck.

So now i have a running cart but it doesnt go the speed it should. I picked up an mcor from a buddy who also works on carts. Should i try that next?
Jkirby891 is offline   Reply With Quote
Reply

Tags
controller issue, new batteries, no power
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
wiring a reverse light to the reverse buzzer? Gas Yamaha
F/r switch help. Reverse buzzer is on in forward and not on reverse Electric EZGO
Reverse buzzer sounds even when not in reverse Columbia ParCar
2007 Drive, no clicks, no reverse buzzer, batteries ok Electric Yamaha
G8e too much power to motor in reverse Electric Yamaha


All times are GMT -5. The time now is 01:15 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.