lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-02-2014, 01:52 PM   #1
kepyslap
Not Yet Wild
 
Join Date: Oct 2014
Posts: 2
Default Headlight/taillight issues

I just purchased a LGT-304 headlight/taillight kit for my EZGO TXT. Installation was successful and running the wires with connectors was no problem. Everything is hooked up but when I turn everything on I get nothing. With my volt meter I have 12.5 volts running through the wire harness and there is 12.5 volts at each plug. The fuse is good and I even bought a new push/pull switch but still no headlights or taillights. Any thoughts?
kepyslap is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-02-2014, 02:20 PM   #2
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 17,139
Default Re: Headlight/taillight issues

Golf carts are two wire systems and it sounds like you have only checked out the +12V side of the system.

There should be a wire that connects each light to the negative terminal of the battery or voltage reducer as well as the one that connects to the positive 12V source.
JohnnieB is offline   Reply With Quote
Old 11-02-2014, 02:35 PM   #3
kepyslap
Not Yet Wild
 
Join Date: Oct 2014
Posts: 2
Default Re: Headlight/taillight issues

Johnie,
Thanks for the info. So the kit was all pre-wired and all wires are in plastic tubing. I have the main positive wire connected to a positive post and the negative connected to a negative post on the next battery giving me the 12 volts. Is this what you are talking about?
kepyslap is offline   Reply With Quote
Old 11-02-2014, 02:46 PM   #4
TrickCart
Getting Wild
 
TrickCart's Avatar
E-Z-GO
 
Join Date: Aug 2014
Location: Saint Louis, Missouri
Posts: 89
Default Re: Headlight/taillight issues

There should be a seperate black wire coming off each light, they need to be grounded aswell (on a battery, not the chassis)
TrickCart is offline   Reply With Quote
Old 11-02-2014, 03:43 PM   #5
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 17,139
Default Re: Headlight/taillight issues

Quote:
Originally Posted by kepyslap View Post
Johnie,
Thanks for the info. So the kit was all pre-wired and all wires are in plastic tubing. I have the main positive wire connected to a positive post and the negative connected to a negative post on the next battery giving me the 12 volts. Is this what you are talking about?
Yep. That should have done it.

Basically, those are stock EZGO lights, so a wiring diagram for stock accessories might help you troubleshoot it.
Attached Images
File Type: jpg Accessory Wiring.JPG (80.8 KB, 0 views)
JohnnieB is offline   Reply With Quote
Reply

Tags
headlights
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Headlight / taillight question. Electric Yamaha
Yamaha G1 Headlight/Taillight options Gas Yamaha
New Headlight/Taillight Kit problems!!! Electric Club Car
Headlight,taillight wiring diagram. Electric Club Car
Need help with headlight/taillight wiring Gas Club Car


All times are GMT -5. The time now is 08:33 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.