lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Melex


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-09-2013, 08:06 AM   #1
dan1508
Not Yet Wild
 
Join Date: May 2013
Posts: 3
Default Melex 512 Not moving

I have a Melex 512 that when we put it away in the fall it moved fine. Now that it's warmed up I've tried to run it and when I step on the gas the motor runs, but it doesn't engage and move.

I know in previous years we've sat for a few while it warmed up and moved, but I did that for over 20 minutes and nothing.

Is there something else I should be looking for and checking or does it just need some more warm up time? any help is very appreciated.
dan1508 is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Melex


Thread Tools
Display Modes


Similar Threads
Thread Forum
not moving Electric EZGO
Need Help with 00 TXT Not Moving Electric EZGO
80 cc 36v not moving Electric Club Car
85 CC not moving Electric Club Car
HELP!! Moving and need JOB! Announcements


All times are GMT -5. The time now is 12:04 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.