lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-02-2021, 10:00 PM   #11
Acidrain
Not Yet Wild
 
Join Date: May 2016
Posts: 11
Default Re: 2003 TXT w/295cc 4-stroke won't start

Quote:
Originally Posted by trig123 View Post
Before you install that new pulser OHM it and compare with yours.
Great idea
Acidrain is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-06-2021, 07:02 PM   #12
Acidrain
Not Yet Wild
 
Join Date: May 2016
Posts: 11
Default Re: 2003 TXT w/295cc 4-stroke won't start

Got my new Pulsar today... wrong one.
It turns out Vintage Golf Cart Parts does not carry the MCI (2003 and newer) pulsar coil.
Looking all over the internet, it looks like it's an out of stock item.
Any ideas out there on where to look/go for this item?

BTW, this pre-MCI pulsar checked out at .209 ohms.
I hope Trig123 checks in... Why .20 OHMS, not 20 ohms as described in the video? Are these two models that much different?
No matter where I set the scale, the decimal is always is the same. .2 or .20, or .209 ohms.

FYI for anybody else struggling: Pre-MCI bolt pattern is 1-3/16".
MCI is 1-7/16. They are physically different but use the same electrical connector.
Acidrain is offline   Reply With Quote
Old 04-07-2021, 07:18 AM   #13
JPonLKN
Gone Wild
 
JPonLKN's Avatar
E-Z-GO
 
Join Date: Jul 2020
Location: NC
Posts: 428
Default Re: 2003 TXT w/295cc 4-stroke won't start

Quote:
Originally Posted by Acidrain View Post
Got my new Pulsar today... wrong one.
It turns out Vintage Golf Cart Parts does not carry the MCI (2003 and newer) pulsar coil.
Looking all over the internet, it looks like it's an out of stock item.
Any ideas out there on where to look/go for this item?

BTW, this pre-MCI pulsar checked out at .209 ohms.
I hope Trig123 checks in... Why .20 OHMS, not 20 ohms as described in the video? Are these two models that much different?
No matter where I set the scale, the decimal is always is the same. .2 or .20, or .209 ohms.

FYI for anybody else struggling: Pre-MCI bolt pattern is 1-3/16".
MCI is 1-7/16. They are physically different but use the same electrical connector.
They are an out of stock item...good luck finding one.

Sounds like your VOM is not working properly. As you change the scale, it should change the decimal place and the number of places visible. Considering the issue with the VOM, take your original Pulsar coil to an auto parts store or repair shop, computer repair shop, HVAC repair van, basically any technician that has a quality VOM that relies on it day/in and day/out and see if they can check the resistance on it. I have had to replace the connectors on one of them, just used bullet connectors. The wire to pin connection was bad in it...took forever to figure it out...found that moving the connector while checking for spark would give me spark sometimes. I've also had to clean the pick-up surface on one of them in the past...made a huge difference, but it ohm'd correctly to start with.

Yes, they have a different bolt pattern and different color wires, i think white and red/white on the Pre-MCI, and Blue and green on the MCI Pulsars.
JPonLKN is offline   Reply With Quote
Old 04-07-2021, 03:12 PM   #14
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: Alabama
Posts: 1,903
Default Re: 2003 TXT w/295cc 4-stroke won't start

I know a dealer who has them. He had nine a few weeks ago.

I use the cheap HB DVOM and it works for me. Maybe get another one or like JPonLKN said get someone to test it with theirs.

The MCI pulser should show a reading of
433.5 - 586.5 ohms
Here is a picture of mine that I just checked off a Pre MCI. I set my meter to the 200 ohm scale.
Attached Images
File Type: jpg meter from hf.jpg (171.7 KB, 0 views)
trig123 is offline   Reply With Quote
Old 04-07-2021, 09:56 PM   #15
Acidrain
Not Yet Wild
 
Join Date: May 2016
Posts: 11
Default Re: 2003 TXT w/295cc 4-stroke won't start

Thanks guys!
Especially thank you Trig! I think it's me. I'm not familiar (obviously) with testing resistance.
The HF and Omega both test exactly the same, and when going back and re-looking, the existing pulsar tests .509 on 2K setting, so move the decimal 3 places and get 509 ohms? That puts me within range for an MCI. Am I correct?
Also, I pulled out my old ignitor, which was probably fine when I switched to GM HEI. Funny thing is, when I switched to the aftermarket ignitor, it was running fine for that last two or three years.
Anyway, I switched it back to the original ignitor and re-wired the entire harness. Tested all of the wires and connectors from one end to the other and find no issue with the wires and connectors. I'll grind/clean all the ground wires too.
I have to repair the two ends of the secondary coil wires, but I have the parts, and the coil tests as follows:
Primary 2.4 on 200 setting, so that checks out.
Secondary 11.70 on 20K, and 11.6 on 200K, so I think those check out OK too?
And finally, part of the work I did was install new plugs... NGK BKR5E's.
Are those correct for the MCI?
I think I'm going to put it all back together and try it unless I've completely miss-read the VOM or you guys think that would be a mistake.
Let me know if If that sounds like a good idea. I really appreciate EVERYBODIES input!
Acidrain is offline   Reply With Quote
Old 04-07-2021, 11:11 PM   #16
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: Alabama
Posts: 1,903
Default Re: 2003 TXT w/295cc 4-stroke won't start

I would say put it back together. Everything looks great according to your readings. Plugs are correct.
Let us know how it works out.
trig123 is offline   Reply With Quote
Old 04-08-2021, 09:10 PM   #17
Acidrain
Not Yet Wild
 
Join Date: May 2016
Posts: 11
Default Re: 2003 TXT w/295cc 4-stroke won't start

I put it all back together, and it fired right up!
I changed so many things, it's hard to say what it was. Here is the list:
New sparkplugs and connectors.
Cleaned and tested all existing in-line electrical connections.
Replaced most of the wiring and terminal ends changing from spade connectors to ring connectors when possible.
Removed, cleaned /ground all of the large ground connections
Dumped the GM HEI ignitor and installed the old stock unit.
Put the battery on the charger and checked for full charge/battery condition.
Checked Ignition coil and pulsar coil for correct resistance.

Anyway, thank you everybody for the help! Now I can start on some minor mods like paint, new front brush guard, seat covers, etc.
Gonna paint it like an army truck lol.
Acidrain is offline   Reply With Quote
Old 04-09-2021, 11:14 AM   #18
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 2,905
Default Re: 2003 TXT w/295cc 4-stroke won't start

When this thread first popped up, I was thinking that you were one of the very few people to get the HEI mod to work on the 4 stroke.

Now I see that you went back to the original ignitor, so apparently not.
cart around is offline   Reply With Quote
Old 04-09-2021, 04:54 PM   #19
Acidrain
Not Yet Wild
 
Join Date: May 2016
Posts: 11
Default Re: 2003 TXT w/295cc 4-stroke won't start

Quote:
Originally Posted by cart around View Post
When this thread first popped up, I was thinking that you were one of the very few people to get the HEI mod to work on the 4 stroke.

Now I see that you went back to the original ignitor, so apparently not.
Actually, it worked great for 2 or 3 years. I use the cart on my property all the time with no issues.
I'm fairly certain that the issue was either the corroded sparkplug wire (one affects both) or bad connectors/wiring/ground.
Acidrain is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
4 Stroke 295cc Robin Gas EZGO
What all years will a Robin 295cc 4 stroke fit? Gas EZGO
91" 295cc 4 stroke firing problem Gas EZGO
EZ-GO 4 stroke gas engine 295cc Rebuilt Golf Carts and Parts
Muffler I Need One Ez Go 94 295cc 4 Stroke Gas EZGO


All times are GMT -5. The time now is 02:20 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.