lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-13-2012, 08:32 PM   #1
stevek
Not Yet Wild
 
Join Date: Oct 2012
Posts: 10
Default 1983 Robin quit running

I have a 1983 ez go cart with a robin 244cc. engine. It has been running fine until yesterday when it started smoking and then would not run anymore. I towed it to the garage and began trouble shooting the problem. There is gas up to the carburetor, and the plug is getting wet as well as fuel is collecting in the air intake. When I dry the plug, it will run for a short time(only secs.)enough to move it a few feet. I have run it with too rich a mixture, and have drained rich fuel and replaced with oil free gas to try to obtain the 128:1mix. The oil injection is not working to my knowledge. We have been running this cart for about one year with no problems to speak of until this..
stevek is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-13-2012, 09:03 PM   #2
LiL' rascal
Getting Wild
E-Z-GO
 
Join Date: Feb 2012
Location: NW Oregon
Posts: 133
Default Re: 1983 Robin quit running

Check your compression, you might have a blown crank seal or maybe just time for a top end rebuild.
You can spray some starting fluid at the crank seal by the clutch and if it pops and fires that could be your problem.

But I'm sure someone will chime in with more knowlage than me.
LiL' rascal is offline   Reply With Quote
Old 10-14-2012, 07:13 PM   #3
sassycat
Gone Wild
 
sassycat's Avatar
E-Z-GO
 
Join Date: Sep 2012
Location: bikini state
Posts: 2,715
Default Re: 1983 Robin quit running

lil rascal summed it up pretty good imo..from what ive read the only thing most have to do once a yr is take the head off and scrape the carbon out and put back together with a new gasket and they run forever..im anxious to learn what your problem is so i learn more myself..hope ya get her figured out soon,john
sassycat is offline   Reply With Quote
Old 10-14-2012, 09:42 PM   #4
racin161
Gone Wild
 
Join Date: Feb 2011
Posts: 1,515
Default Re: 1983 Robin quit running

Sounds like there is a piece of trash between the needle and seat causing it to flood. I think with a good carb cleaning you'll be good to go.

LOU
racin161 is offline   Reply With Quote
Old 10-14-2012, 10:12 PM   #5
LiL' rascal
Getting Wild
E-Z-GO
 
Join Date: Feb 2012
Location: NW Oregon
Posts: 133
Default Re: 1983 Robin quit running

Racin161 has a good point. I'd try that first
LiL' rascal is offline   Reply With Quote
Old 10-14-2012, 10:18 PM   #6
1fast67
Gone Wild
 
1fast67's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: spokane,wa
Posts: 974
Default

I had the same kind of problem and what i found was my choke cable was adjusted wrong. It was half closed making it run rich and i also had fuel in the air cleaner tube.

Sent from my LG-P999 using Tapatalk 2
1fast67 is offline   Reply With Quote
Old 10-15-2012, 09:15 AM   #7
stevek
Not Yet Wild
 
Join Date: Oct 2012
Posts: 10
Default Re: 1983 Robin quit running

I am going to try the carb cleaning first, as that is probably the easiest thing and because the buggie was running fine and starting very easily until I made a turnaround at the end of the driveway. I am thinking that a stuck float and dirty needle valve may be causing the carb to fill with gas and flood the cylinder and pour back into the intake. I am not much of a mechanic, so am wondering if I have my thinking cap on straight? Are parts readily available for these engines?
stevek is offline   Reply With Quote
Old 10-15-2012, 09:40 AM   #8
1fast67
Gone Wild
 
1fast67's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: spokane,wa
Posts: 974
Default

Heres a diagram of the carb. The parts that are circled needs to cleaned the best as they are the jets.

Sent from my LG-P999 using Tapatalk 2
1fast67 is offline   Reply With Quote
Old 10-15-2012, 01:03 PM   #9
stevek
Not Yet Wild
 
Join Date: Oct 2012
Posts: 10
Default Re: 1983 Robin quit running

thanks for the diagram, it will be very helpful I am sure. I will let you know how it goes.
stevek is offline   Reply With Quote
Old 10-15-2012, 06:56 PM   #10
stevek
Not Yet Wild
 
Join Date: Oct 2012
Posts: 10
Default Re: 1983 Robin quit running

Cleaning the carb did not help. The engine seems to be starting, but not accelerating enough to engage the belt drive to propel the cart.
stevek is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Quit running Gas EZGO
85 Gasser quit running Gas EZGO
got it running then quit Gas EZGO
G22 running good, and then just quit Electric Yamaha
quit running Electric Club Car


All times are GMT -5. The time now is 08:32 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.