lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-19-2014, 06:40 PM   #1
goldwinger
Gone Wild
 
Join Date: Jul 2014
Posts: 314
Default G2a messed up

I just bought a 1990 G2A and it has no spark and wont turn over unless I cross the solinode with a screw driver.what could be the problem?
goldwinger is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-19-2014, 08:09 PM   #2
pachanga90
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hilton,NY
Posts: 5,424
Default Re: G2a messed up

Check the fuse(s) first,Make sure the pedal-switch under the cart is connected.Ive seen them unplug from catching something while riding.That will cause the solenoid to not work.If you are getting voltage to 1small stud on the solenoid with the pedal pressed,make sure the other small wire has a good ground circuit,if so,the solenoid is bad.Go to a snow-plow/truck equipment supplier and ask for a 12v continuous-duty solenoid,not a starter-solenoid(they wont last a day on a cart,they are intermittent-duty).Hope this helps.
pachanga90 is offline   Reply With Quote
Old 09-19-2014, 08:39 PM   #3
goldwinger
Gone Wild
 
Join Date: Jul 2014
Posts: 314
Default Re: G2a messed up

I looked at what u said and all is good.so what now?
goldwinger is offline   Reply With Quote
Old 09-19-2014, 08:51 PM   #4
pachanga90
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hilton,NY
Posts: 5,424
Default Re: G2a messed up

If the hot and ground are good,and it only spins when jumping the terminals, then replace the solenoid.Does it click when pedal is pressed?Does voltage appear at small stud when pedal is pressed?
pachanga90 is offline   Reply With Quote
Old 09-20-2014, 09:07 AM   #5
Mike Mac
G8 Specialist
Yamaha
 
Join Date: Jun 2009
Location: Phoenix
Posts: 7,799
Default Re: G2a messed up

I might add, load test the batt before you spend money!!
Mike Mac is offline   Reply With Quote
Old 09-20-2014, 09:15 AM   #6
pachanga90
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hilton,NY
Posts: 5,424
Default Re: G2a messed up

Yep,I forgot the important question,how many volts does batt have?
pachanga90 is offline   Reply With Quote
Old 09-20-2014, 12:10 PM   #7
goldwinger
Gone Wild
 
Join Date: Jul 2014
Posts: 314
Default Re: G2a messed up

battery is showing 12.51 volts
goldwinger is offline   Reply With Quote
Old 09-20-2014, 02:22 PM   #8
goldwinger
Gone Wild
 
Join Date: Jul 2014
Posts: 314
Default Re: G2a messed up

Wow how simple..well I got it running a hour ago.i traced all wireing with my meter all was good except when I got to the voltage regulator.there is a red/white wire and a black wire going to it both have glass fuse in them and both have a old style fuse holder that is made of rubber that you put the fuse in and it snapps together and they are removable.so I pulled both fuse and were both good still noting so I took off the fuse holder and and put the fuse back in each one and shook the hell out of it and heard a rattling noise..and hell that was the problem both fused wires was not making contact.so I rigged the fuse holders and put them back on an HEll YA it started
So im going to replace the old black rubber fuse holders with the inline blade fuse holder.......And many thanks to the guys that responded to my post.

CHIN UP,FOOT DOWN AND ELBOW IN THE DRINKING MODE!!!!!!!!!!
goldwinger is offline   Reply With Quote
Old 09-20-2014, 08:42 PM   #9
Mike Mac
G8 Specialist
Yamaha
 
Join Date: Jun 2009
Location: Phoenix
Posts: 7,799
Default Re: G2a messed up

Good deal Winger!! Enjoy!! I replaced the fuse holders on mine too!!
Mike Mac is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
I messed up my Lights! Help Please. Electric Club Car
Messed up my lights, looking for some help..... Electric Club Car


All times are GMT -5. The time now is 11:39 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.