lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Icon


Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-10-2024, 06:58 AM   #1
Dirtfarmer
Not Yet Wild
 
Join Date: Jun 2010
Posts: 5
Default 2020 ICON I4 not charging

Need some help. Lead acid battery cart runs and drives (for now). Currently have 47 volts at the battery pack. When I plug the charger cable in, no lights come on at the charging port and charger is cool to touch. Bought a new charger cable, no change.

I cleaned and reset all the battery cables and still no charging. I've cycled the key several times, no change. Obviously the lead acid batteries are reaching end of life, but I'm reluctant to swap them out for fear that the charging system may have a problem.

Has anybody had this issue, any advice?
Dirtfarmer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Icon


Thread Tools
Display Modes


Similar Threads
Thread Forum
2020 icon i60l - clicking noise (see video) Icon
2020 Icon I40L Review Icon
ICON Charging Cable Icon
My 2020 Icon I40 review Icon
2020 Onward 6P not charging after Alltrax Install Electric Club Car


All times are GMT -5. The time now is 10:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.