lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-05-2010, 06:56 PM   #1
brymor31
Not Yet Wild
 
Join Date: Feb 2010
Posts: 3
Default 2006 EZ Go PDS charging problem

Just installed an Alltrax 400 and now cart wont charge. Batteries are new and were charged before the new controller. Cart runs fine and I have a green light on the controller.

Battery pack voltage is 33.6 after using the cart around the neihborhood today. When i plug in the charger...nothing....its like its dead. If i take off the + battery cable the charger will click on and the needle jumps to 10 amps but then immediately goes back to 0.

Powerwise II charger.

Any thoughts or suggestions? Thanks.
brymor31 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-05-2010, 07:24 PM   #2
SpoiledRotten
Conservatively Wild
 
SpoiledRotten's Avatar
E-Z-GO
 
Join Date: Aug 2009
Location: Below the Mason Dixon
Posts: 3,609
Default Re: 2006 EZ Go PDS charging problem

Sounds like something definitely wrong with your battery pack for the voltage to be that low. Did you check each battery individually? Some others will chime in, but that is definitely too low just to have run around the neighborhood. I don't think they should ever get below around 35 volts and even that low is probably showing a dead cell or something similar, but I'm not the expert. Check for lose cables at each terminal of the batteries and the controller.
SpoiledRotten is offline   Reply With Quote
Old 08-05-2010, 07:49 PM   #3
brymor31
Not Yet Wild
 
Join Date: Feb 2010
Posts: 3
Default Re: 2006 EZ Go PDS charging problem

Been on the charger now for about 2 hours. Chargers reads 0 but you can feel that it is on. Battery pack now reads 35.4. Each battery reads 5.9 or 5.91.

I did notice that in the charger plug, the one that plugs into the cart, there is a little metal piece on one side but not the other. the two prongs are there but only one of the little metal clip things.

The batteries have been fully charged before but not fully charged before using it today. Pack voltage was only 36.1 before using it today.

Left the charger on overnight a few days ago and only charged it to 36.1.

All cables tight.
brymor31 is offline   Reply With Quote
Old 08-05-2010, 08:28 PM   #4
brymor31
Not Yet Wild
 
Join Date: Feb 2010
Posts: 3
Default Re: 2006 EZ Go PDS charging problem

Got it Thanks. Didnt connect black wire from charger to - of battery pack. DUH!!
brymor31 is offline   Reply With Quote
Old 08-05-2010, 08:34 PM   #5
golfcarfixer
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: Forest City N.C.
Posts: 2,660
Default Re: 2006 EZ Go PDS charging problem

Ahhhh man we thought we had a problem. Dang glad you got it fixed.
golfcarfixer is offline   Reply With Quote
Old 08-06-2010, 06:05 AM   #6
SpoiledRotten
Conservatively Wild
 
SpoiledRotten's Avatar
E-Z-GO
 
Join Date: Aug 2009
Location: Below the Mason Dixon
Posts: 3,609
Default Re: 2006 EZ Go PDS charging problem

Good for you!
SpoiledRotten is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging problem??? Electric Club Car
Charging Problem Electric EZGO
2006 48v electric club car charging problem Electric Club Car
2006 Precedent runs slow. Is there a problem? Electric Club Car
Charging problem Electric EZGO


All times are GMT -5. The time now is 07:46 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.