lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-20-2014, 12:35 PM   #1
Bodave2
Not Yet Wild
 
Join Date: Dec 2014
Posts: 6
Default EZ-GO 36v medalist series cart speed/torque issue

Hi guys, i recently got my father a cart off of craigslist for Christmas and after a week or two of running slow, I have had trouble getting her to run properly. Soon after I bought it it stopped working. I first replaced the solenoid, nothing. Then I installed a alltrax 400amp speed controller, nothing. I finally had one of my friends come out with a multimeter and we found there was no voltage going to the small positive terminal at the solenoid and no clicking sound. The LED on the speed control was not lighting up too. We pulled out the ignition and there was no voltage there also. So we rigged up our own wiring from the battery to the ignition and now it works. Every time i press the gas the controller lights up and turns off when i release the gas. Is that correct? Also i had to replace the steering rack and gears and that was a bitch but now i have no play in the wheel. So now after all this work, the cart still has very little torque going up hill i had hoped the bigger controller i got would make it have more pep but its slow. Am i expecting too much from her? The golf course my dad lives on has alot of hills and i want to get this sucker better for Christmas, please help.
Bodave2 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-21-2014, 12:51 PM   #2
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,442
Default Re: EZ-GO 36v medalist series cart speed/torque issue

Did you check the throttle for proper 0-5k ohm operation? Do you know what settings are set in the controller? Does the green light turn orange at full throttle (indicating 100% throttle)?
cgtech is offline   Reply With Quote
Old 12-21-2014, 02:47 PM   #3
Bodave2
Not Yet Wild
 
Join Date: Dec 2014
Posts: 6
Default Re: EZ-GO 36v medalist series cart speed/torque issue

Quote:
Originally Posted by cgtech View Post
Did you check the throttle for proper 0-5k ohm operation? Do you know what settings are set in the controller? Does the green light turn orange at full throttle (indicating 100% throttle)?
How would I check throttle ? I could not get to the switch from underneath. I will check to see if i get orange light but i have only seen green solid light. Ill jack up the back and floor it and post results.

Update: controller light is orange when pedal is on the floor. Controller is the non-programmable ITS 4844 new out of the box. I have the factory solenoid still does that matter?
Bodave2 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric Motor Issue - Series cart Electric EZGO
ezgo series cart controller issue Electric EZGO
2003 DS Series Speed Issue Electric Club Car
94cc 36v torque & speed series cart Electric Club Car
94 Medalist speed/torque upgrade Electric EZGO


All times are GMT -5. The time now is 12:42 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.