lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-24-2011, 08:17 PM   #1
Obee
Not Yet Wild
 
Obee's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: KS
Posts: 64
Default Engine OH Went Well But Need Some more Advice

Just put in new top and bottom kit on my '87 EZ GO. Went smooth and fired off with only above three revolutions. Took it out today and it starts right off but no power up top, won't rev up. Pulled plug out when I got home from 18 holes and it is tan to dark tan in color, looks good to me for a 4 stroke but not sure on the 2 timers. I mixed the gas at 40:1 as I was told in my other post "Engine Went Thunk".

Does it matter which nipple on the fuel pump goes to the carb or which way the pump goes on? Right now the angled nipple is towards the spark plug end or drivers side and I have the line from the tank going into this nipple.

Did the muffler check on the old motor and no change in the way it ran. It really feels like it is lean or retarded timing. Runs smooth as silk. I haven't tried to see if it will run any faster in reverse. I pulled the choke out a lil bit but no help at all in the way it ran. After seing plug and pulling choke out I kinda ruled out the lean part. Looked at the ground strap on the plug and the timing looks fine too..........for a 4 stroke.

Took carb apart again and it is clean as a whistle, took extra time and made sure three times. Air filter is new. Choke is not out of adjustment. New fuel filter. Blew out line into fuel tank before engine went in.

Thanks for all the help in getting it back together, I didn't ask but found your help in the search box!

Thanks!

Regards, Jeff
Obee is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-25-2011, 09:31 PM   #2
Obee
Not Yet Wild
 
Obee's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: KS
Posts: 64
Default Re: Engine OH Went Well But Need Some more Advice

Played some more today and I noticed that at 40:1 mix there is no visible smoke. I figured it would smoke like a freight train at this ratio? Does this help at all in a diagnosis? Starts great and runs good just no power or rpms. Drove a '88 two weeks ago while mine was down and it reved up like a chain saw.

Ran exactly this way with old engine except old engine was very hard to start and ran very rich all the time, with the plug being wet. This one doesn't run rich and plug is dry. Thinking maybe I need to drop the coin for a new carb?

Thanks!

Regard, Jeff
Obee is offline   Reply With Quote
Old 09-27-2011, 07:56 PM   #3
Obee
Not Yet Wild
 
Obee's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: KS
Posts: 64
Default Re: Engine OH Went Well But Need Some more Advice

Haven't made any progress yet with diagnosis. Starts, idles, runs around like a watch just won't rev up good and is sluggish on hills. I do have the shorter belt on it, new. The governor is not hooked up so can eliminate that.

Thanks!

Regards, Jeff
Obee is offline   Reply With Quote
Old 09-27-2011, 09:19 PM   #4
ScooterMcTavish
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: Engine OH Went Well But Need Some more Advice

Hey Jeff,

My initial thought was the carb, but it sounds like you had that covered. Though, a small plug in the feeder screw on the bowl, having the feeder screw lined up incorrectly (the holes in the screw have to be lined up with the depressions in the bottom of the carb bowl), or a piece of dirt in the intake jet could all rob you of some fuel that you need to get revs.

One simple thing to check is where the throttle lever is on the carb. Is it potentially catching on anything? I know when I hooked my air intake back up to my carb, I had the screw nut on the clamp at the top, and it kept the throttle lever from moving as far forward as it needed to be to rev up.

Good also to check the action with the drive belt off or the cart on stands. If you have someone move the pedal, you can check the action on the lever. This could ID or eliminate a cable problem.

Good to also check the idle screw in the carb. It should be screwed in all the way, then be backed out 1 1/2 turns.

The shorter belt will make it more sluggish until it gets broken in, but you shouldn't lose your top end revs. Plus, it shouldn't be sluggish up hills.

Some ideas for you anyways. If you need a picture of a fuel pump hooked up correct, let me know.
ScooterMcTavish is offline   Reply With Quote
Old 09-27-2011, 10:45 PM   #5
Obee
Not Yet Wild
 
Obee's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: KS
Posts: 64
Default Re: Engine OH Went Well But Need Some more Advice

Thank you so much for your suggestions!

Throttle cable is free and opens carb all the way.

Carb screw was bottomed out gently and turned out about 2 turns.

Not sure about the feeder screw alignment, will need to take it off and apart again to see if it makes more sense to me then?? Hopefully I can do that tomorrow night.

Would love to see pics of the fuel pump hose routing. I hooked it up the way it was before. Have an inline fuel filter before the pump.

Only thing left from original engine is the carb and ignition system.

Thanks again!

Regards, Jeff
Obee is offline   Reply With Quote
Old 09-28-2011, 07:17 AM   #6
ScooterMcTavish
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: Engine OH Went Well But Need Some more Advice

I had a similar problem with my carb bowl - this will generally happen if you put the bolt in too tight. Good to use a sharpie to mark a proper alignment then wrench her in!

This photo might help - if you need another, let me know....

ScooterMcTavish is offline   Reply With Quote
Old 09-28-2011, 07:40 AM   #7
madoc1
no clue
 
madoc1's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: spicewood, texas
Posts: 3,308
Default Re: Engine OH Went Well But Need Some more Advice

your fuel pump should have arrows on the top showing gas flow. you can just pull the line from the carb and turn the engine over to see if you have steady pulse of gas. it does sound as tho you are getting gas.
also do as scooter said and put it up on stands and check the results.
madoc1 is offline   Reply With Quote
Old 09-28-2011, 07:44 AM   #8
Obee
Not Yet Wild
 
Obee's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: KS
Posts: 64
Default Re: Engine OH Went Well But Need Some more Advice

Thanks for the photo but mine is a '87 with the 244 2PG. This photo is of the engine before OH. Disregard the colored circles as this was for a different post.



Didn't kow the fuel bowl orientation would make a difference. I will pull the carb and tke a close look at this.

Will put on stands also.

Thanks!

Regards, Jeff
Obee is offline   Reply With Quote
Old 09-28-2011, 09:32 AM   #9
Ga_goat
Getting Wild
E-Z-GO
 
Join Date: Jan 2010
Location: Valdosta Ga.
Posts: 76
Default Re: Engine OH Went Well But Need Some more Advice

Some of the 2 cycle oil is smokeless , are you mixing oil in the tank and useing an oil pump ? ,, noticed the oil line still attached to manifold .
Ga_goat is offline   Reply With Quote
Old 09-28-2011, 02:30 PM   #10
ScooterMcTavish
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: Engine OH Went Well But Need Some more Advice

FWIW, I didn't smoke on my 40/1 mix for the first tank either.

Only smoke I had was right after rebuild as it worked the assembly oil off, and as it heated up my bunged muffler (before BBQ).
ScooterMcTavish is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G9 Engine Rebuild Advice Gas Yamaha
Need Advice on G2 Engine Gas Yamaha
rebuiling a 1998 ezgo gas engine 295 any advice Gas EZGO
G1 Engine Rebuild...need advice Gas Yamaha
Gas engine upgrade for 97 Club Car advice Gas Club Car


All times are GMT -5. The time now is 12:52 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.