lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-19-2022, 11:51 AM   #11
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 5,644
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

Well, I seem to have some "other issues" when I was messing around with my setup.

My ZEVA touch screen is giving me some issues. I can "touch" through the different display settings, and then when I hold my finger on the touch screen to enter "SETUP"...I can get into the setup data. However, I cannot, hitting the touch screen button, get the "EXIT SETUP" to respond.

I can reset the BMS with the "sleep" switch, but when I do that any changes I made in Setup are not saved.

So....I don't know if this is a ZEVA BMS issue, or a touch screen issue. Or if it's possibly a wire\connect issue between the touch screen and the unit.

I've sent an email to Ian for a response, but on his website he has stated he no longer sells the ZEVA BMS, but he will respond to previous clients inquiries.

I'm going to search the web and see if there are any US ZEVA dealers that can provide me with any help.
DaveTM is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-19-2022, 02:02 PM   #12
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 5,644
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

I thought perhaps the ZEVA touch screen issue may have been the wiring behind the screen. The screen has been "bantered about a bit" over the last week, so I pulled out the wires, cut them back, and re-inserted. That was not the issue.

Touch screen is acting veery funky. Touch it where there is suppose to be "nothing" but it will move to another setting. Touch where you're suppose to.....get nothing...then suddenly get something.

Doesn't appear to be a physical issue with the screen. I can change\use icons that appear at the screen bottom.....but when in setup mode, and to use the exit button located at the bottom of the screen.....nothing happens.

Software issue? I dunno if these can be reset or not.
DaveTM is offline   Reply With Quote
Old 11-19-2022, 03:21 PM   #13
Pat911
Gone Wild
Club Car
 
Join Date: Dec 2020
Location: Melbourne, Australia
Posts: 972
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

Sounds like the touch calibration is off, i.e. the screen doesn’t know where you’re actually touching it. Is there a screen or touch calibration setting in the menus anywhere.
Pat911 is offline   Reply With Quote
Old 11-19-2022, 04:50 PM   #14
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 5,644
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

Quote:
Originally Posted by Pat911 View Post
Sounds like the touch calibration is off, i.e. the screen doesn’t know where you’re actually touching it. Is there a screen or touch calibration setting in the menus anywhere.
No. I’ve never come across that nor is there any instructions to that. I did manage to change a few settings before it went wonky. I set the pack charge to 56v and the “full charge “ setting to 55v.

I know that “leaves some on the table” , but I need to check the charger issue first…as soon as I can figure out how to test the output of a smart charger….the issue that started it all.

For the screen....(see pic below....even though this screen pic doesn't have Icon buttons)....You have to touch it below where the actual icon is. And the "leave settings" button is located at the bottom....thus off the screen and unable to work.

DaveTM is offline   Reply With Quote
Old 11-19-2022, 05:24 PM   #15
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 5,644
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

I'm wondering if I just remove the power to the BMS, then re-connect if that would reset the touch screen??

Any thoughts?
DaveTM is offline   Reply With Quote
Old 11-19-2022, 06:33 PM   #16
Pat911
Gone Wild
Club Car
 
Join Date: Dec 2020
Location: Melbourne, Australia
Posts: 972
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

What you’re describing are the exact symptoms for a touchscreen that is incorrectly calibrated.

You’ve got nothing to loose trying that except if the BMS looses all its settings, but I doubt that very much as I would expect the settings to be stored in non-volatile RAM.
Pat911 is offline   Reply With Quote
Old 11-20-2022, 11:34 AM   #17
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 5,644
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

Pulled the power from the BMS. Gave it some time to bleed out any power. Reconnected it and back to the same issue.

I did use my MM to check the voltage of each cell & compared to the BMS & all checked out. All volts are the same in each cell compared to MM.

I don’t know what makes a touch screen work. I assume some piece of software. But…I also would think the hardware plays a part.
DaveTM is offline   Reply With Quote
Old 11-20-2022, 03:21 PM   #18
Pat911
Gone Wild
Club Car
 
Join Date: Dec 2020
Location: Melbourne, Australia
Posts: 972
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

Both hardware and software plays a part. On some devices you can go into a screen calibration mode which puts objects on the screen and you touch where they are. The software then maps your touches to the correct location for the icons. Looks like your Zeva doesn’t have this setup option in the menus.
Pat911 is offline   Reply With Quote
Old 11-21-2022, 11:45 AM   #19
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 5,644
Default Re: ElCon charger ZEVA BMS...and a charging "thing"

Ok....I managed to find a replacement LED touch screen. The new part appears identical to the existing screen, and the voltages, size, pin hook up all appear identical.

So, if it's wrong or doesn't help, I'm out the $16. I can live with that.

Ordered off of Aliexpress.....says delivery by Dec 13th. We shall see.

I'll update when the part gets here.
DaveTM is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G2 charging problem. "green wire lowers voltage" Gas Yamaha
DPI 48V Charger Flashes Charging and switches to "Detection" Electric EZGO
ZEVA error code "No comms to charger” Lithium EZGO
The "Swamp Thing" Build Gas Yamaha
Check this thing out. Another odd ball "cart". Gas golf carts


All times are GMT -5. The time now is 09:10 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.