lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Tomberlin


Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-06-2022, 09:10 AM   #1
Jhammer
Not Yet Wild
 
Join Date: Mar 2022
Posts: 33
Default 2008 Tomberline Emerge intermittent run

So I have a 2008 Tomberline Emerge E4 I just got it running after sending the controller to FSIP to be rebuilt. It ran on and off for a few minutes at a time however I can hear the main large contactor turning on and off. When I press the accelerator down after the contactor turns on I hear and can see sparks from the main Negitave battery post for pack voltage spark. Im scared to ruin any thing and can't for the life of me figure it out. By the way the connection on the battery post is tight Aswell as the connection to the controller in this case I have a GE 403TB1 controller. When it did run it was not running full speed at 20 to 25 mph and rather maxed out at around 11 mph. The things replace are new speed sensor, newer main contactor, new pedal assembly, new forward/reverse, motor, hall effect sensor, key switch, and new batteries 8 6 volt crown batteries. When we replaced the batteries I replaced the cables aswell however the main cables for pack voltage are old and the cables to the controller are old. Any input is much appreciated thank you.
Jhammer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-07-2022, 12:16 PM   #2
Jhammer
Not Yet Wild
 
Join Date: Mar 2022
Posts: 33
Default Re: 2008 Tomberline Emerge intermittent run

Okay so I cleaned all the connections to the batteries and the sparking has stopped. But now it seems like the speed is around 18 mph but the batteries are draining way to fast. So it take no time at all to see the battery meter lower to the point where I scared to drive it any real distance. When I get done driving it and am getting ready to plug it in I check the tempature by feel on the batteries,controller and the motor are not hot at all just the motor is warm. But I'm having another problem when I'm going at a good speed say 10+ mph when I remove my foot off the accelerator the cart starts slowing down in almost 2 stages. The first stage is a slowing that comfortably and not aggressive at all. The second however is extremely aggressive and sometimes almost locks up the tires is this normal for regenerative braking?
Jhammer is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Tomberlin


Thread Tools
Display Modes


Similar Threads
Thread Forum
16 Tomberline Emerge Rear end clicking Tomberlin
16 Tomberline Emerge Rear end clicking Tomberlin
2007 Emerge intermittent won't do anything. Tomberlin
2010 Emerge 48SS Intermittent Speeds Tomberlin
2010 Tomberline emerge Tomberlin


All times are GMT -5. The time now is 01:09 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.