lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-09-2008, 04:55 PM   #1
etonracn
Not Yet Wild
 
Join Date: Feb 2008
Posts: 4
Default 1981 G1 Starting Problem

Hi There!
Just received a cart from a buddy of mine for free and I can't get it to started. Starter solenoids click but engine will not turn over. Any help would be greatly appreciated.

Thanks In Advance!
James
etonracn is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-09-2008, 06:52 PM   #2
smallblock450sl
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,671
Default Re: 1981 G1 Starting Problem

Quote:
Originally Posted by etonracn View Post
Hi There!
Just received a cart from a buddy of mine for free and I can't get it to started. Starter solenoids click but engine will not turn over. Any help would be greatly appreciated.

Thanks In Advance!
James
Very tough question to awnser...Just because you hear solenoid "clicks" doesn't mean "current" is "flowing" thru them. 1st-I'd see if the engine is "frozen up" by turning the primary clutch...(does it rotate and have compression ?) 2nd-I'd use a volt meter to see if current is going to the starter/generator. You may just have bad starter/generator brushes. Could be so many things at this point. Try these and let us know what you found. Later Dave
smallblock450sl is offline   Reply With Quote
Old 02-13-2008, 05:16 AM   #3
etonracn
Not Yet Wild
 
Join Date: Feb 2008
Posts: 4
Default Re: 1981 G1 Starting Problem

I figured it out. It was the starter solenoids after all. For anyone having problems with these don't buy new ones because they are very simple to fix. All I did was take them apart and cleaned up the disk and flipped the contacts around. Saved me at least a $100
etonracn is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Starting input needed Gas EZGO
need a help with no go problem Electric Club Car
1981 G1 went lame suddenly Gas Yamaha
ezgo no starting no power to accessories Gas EZGO
91 ez-go starting problems Gas EZGO


All times are GMT -5. The time now is 08:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.