lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 01-07-2008, 10:29 PM   #1
jmill
Not Yet Wild
 
jmill's Avatar
 
Join Date: Jan 2008
Location: algonac michigan
Posts: 26
Angry no power

i just took out my cart for the first time today cents the weather here in mi. was 60 degrees, and was the first time cents the the new top end. it started, and took off very slow for about 20- 30 feet and stopped, tryed to start it for about 5 - 10 min, and a couple of times i got it going a little bit but really no power, finally did a compresstion test when i got it back into the garage and that read between 110- 115. any ideas???? thanks joel
jmill is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 01-07-2008, 11:18 PM   #2
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: no power

Did you put the piston in with the holes towards the intake? If thats a yes try running it with the muffler loose to see if its clogged up. last thing If you didn't replace the crank seals that may be the problem, if those are bad your fuel pump and intake won't work right and your engine will starve for gas
ruredy is offline   Reply With Quote
Old 01-08-2008, 09:23 PM   #3
jmill
Not Yet Wild
 
jmill's Avatar
 
Join Date: Jan 2008
Location: algonac michigan
Posts: 26
Talking Re: no power

hey ruredy, thanks so much for your help it was the muffler, and any ideas were to get a custom exhaust ????? (85 ezgo 244 robin)
jmill is offline   Reply With Quote
Old 01-09-2008, 12:27 AM   #4
ruredy
Born Wild
 
ruredy's Avatar
 
Join Date: Mar 2007
Location: Clover SC.
Posts: 5,552
Default Re: no power

No ideas on where to find custom exhaust for those things, I try not 2 deal with 2 strokes 2 much
ruredy is offline   Reply With Quote
Old 01-09-2008, 12:33 PM   #5
mb523
Peanut
 
mb523's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: Western Massachusetts
Posts: 656
Default Re: no power

I would recommend sticking with the original muffler. A lot of times, the issue is that it is simply clogged up with carbon. A muffler BBQ usually solves the problem. Just take it out of the cart and place it into a hot fire. The carbon will burn out and it should be free flowing again.

Did it used to smoke bad when the engine got to temperature? It is common for older 2-strokes to do that.
mb523 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Power Plants On Road Golf Carts!
help no power Electric Yamaha
No Power Electric Club Car
Club Car power Electric Club Car
V-power gas... Gas Yamaha


All times are GMT -5. The time now is 06:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.