lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Restoration
Restoration Early 70's and older restoration projects



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-08-2022, 09:26 PM   #1
ronh
Not Yet Wild
 
Join Date: Aug 2022
Posts: 7
Default Intermittent slow speed on 7 solenoid Pargo empire

Working on a Pargo empire truckster and I've replaced the potentiometer???/pedal switch???, built a completely new harness, and replaced what solenoids I thought I found to not be working. I can hear it click through the other solenoids however, only occasionally will the lower speeds work. Most of the time she's all or nothing both forward and reverse. I don't believe the motor is going to like doing that too long. What should I be testing (which of the solenoids, coils) and how?
Thanks
ronh is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-13-2022, 11:56 AM   #2
Lochlin
Gone Wild
 
Join Date: May 2011
Location: Pittsburgh
Posts: 2,942
Default Re: Intermittent slow speed on 7 solenoid Pargo empire

I would check those motor brushes. If they are worn they won't want to spin with motor with low current. They respond to high current, though, which was cause a lot of whiplash.
Lochlin is offline   Reply With Quote
Old 09-13-2022, 10:14 PM   #3
ronh
Not Yet Wild
 
Join Date: Aug 2022
Posts: 7
Default Re: Intermittent slow speed on 7 solenoid Pargo empire

Thank you. didn't think of that. Are they hard to service? would I have to pull the motor to put in new brushes?
ronh is offline   Reply With Quote
Old 09-14-2022, 01:55 PM   #4
Lochlin
Gone Wild
 
Join Date: May 2011
Location: Pittsburgh
Posts: 2,942
Default Re: Intermittent slow speed on 7 solenoid Pargo empire

The roughest part of brush replacement is normly finding the right brushes! Replacing is pretty easy, though. The motor should just pop off with a few bolts which will give you easy access to the brushes. There are a lot of YouTubes out there that provide a lot of detail.
Lochlin is offline   Reply With Quote
Old 09-16-2022, 06:37 AM   #5
ronh
Not Yet Wild
 
Join Date: Aug 2022
Posts: 7
Default Re: Intermittent slow speed on 7 solenoid Pargo empire

Thank you
ronh is offline   Reply With Quote
Old 10-11-2022, 09:49 PM   #6
ronh
Not Yet Wild
 
Join Date: Aug 2022
Posts: 7
Default Re: Intermittent slow speed on 7 solenoid Pargo empire

Ok. did some more testing. When I give the 2nd solenoid from the right a jump from battery positive to the small top terminal, i have all speeds. When I run a jumper from the 1st speed solenoid to the small top terminal on the 1st forward solenoid from the right, I have all speeds. Same goes for reverse. When I jump positive power from the 1st speed small top terminal to the small terminal on top of the far right solenoid, I have a softer reverse. I have a toggle switch for forward and reverse. it seems to be working fine. could my pedal switch be causing all the trouble??
Attached Images
File Type: jpg Pargo-7Solenoids-wiring-diagram.jpg (47.2 KB, 0 views)
ronh is offline   Reply With Quote
Old 10-13-2022, 11:52 AM   #7
ronh
Not Yet Wild
 
Join Date: Aug 2022
Posts: 7
Default Re: Intermittent slow speed on 7 solenoid Pargo empire

figured it out. pedal speed switch is not making contact on master solenoids.
ronh is offline   Reply With Quote
Old 09-22-2023, 01:01 PM   #8
Tatie
Not Yet Wild
Pargo
 
Join Date: Sep 2023
Location: MO
Posts: 3
Default Re: Intermittent slow speed on 7 solenoid Pargo empire

Hey Ronh. I've just joined today and I have a Pargo GC with the 7 solenoids. My question is the schematic shows a "seat swith" and I can't find a seat switch. I also didn't get a charger with it and there's no charging port. Only thing on the face of the seat housing was a small hole for the F n R with 4 terminals on it rather than three. There's an extra white wire bouncing around. Don't know where it goes, but think it came off the F n R switch. I guess. Kinda lost.
Tatie is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Restoration


Thread Tools
Display Modes


Similar Threads
Thread Forum
Slow speed-5 solenoid/micro switch 1012190 motor Electric Club Car
Keep frying Solenoid at Slow Speed Electric EZGO
2001 Ezgo PDS intermittent slow speed Electric EZGO
90 Yamaha G8 - Slow Speed (SR48500, SW202, 600A Solenoid) Electric Yamaha
intermittent slow speed issue Electric EZGO


All times are GMT -5. The time now is 07:12 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.