lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-26-2015, 11:26 AM   #1
Vineyard Buggie
Not Yet Wild
Yamaha
 
Join Date: Jul 2015
Location: St. Louis
Posts: 3
Default '79 G1 Yamaha - New carb w/ low power and no reverse

My first time dealing with small engines in general (on the repair side...used them quite frequently though)...and I'm not much of a handy man in that regard. I've got a 79 G1 Yamaha and my dad let this thing sit for years...someone had done a hell of a job tearing out the switch assembly, it was rusty, tires were all completely shot, and it was covered in a thick layer of mildew/dirt.



Thing wouldn't even make a sound...figured the battery was no good



So I replaced it with a new one and cleaned all the connections and started hearing a clicking sound, cleaned some more and it started to turn...no movement in the rear, just as if it wanted to, but couldn't. I thought maybe it wasn't getting any fuel/air...which both filters needed to be replaced badly.

I decided to replace instead of clean the old carb. as well as new spark plug, new air and fuel filters. Considering replacing the battery terminal connectors and possibly the solenoids, they look pretty bad, but seem to function still.





Got some new tires on it because the other ones were completely rotted out.



Cleaned up very well and the new carb. got it going, gets going forward (with some power issues), but it still has a hard time getting going in reverse. Any thoughts on why?



Vineyard Buggie is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-03-2015, 08:06 PM   #2
Vineyard Buggie
Not Yet Wild
Yamaha
 
Join Date: Jul 2015
Location: St. Louis
Posts: 3
Default Re: '79 G1 Yamaha - New carb w/ low power and no reverse

I didn't realize that the carburator had a air adjustment and a fuel adjustment...(smacks own forehead). I adjusted both and now I'm getting consistent power forward and somewhat power in reverse. I guess tinkering is in order?
Vineyard Buggie is offline   Reply With Quote
Old 08-06-2015, 04:40 PM   #3
Cvans
Gone Wild
 
Cvans's Avatar
Yamaha
 
Join Date: Apr 2013
Location: Eastern SD.
Posts: 276
Default Re: '79 G1 Yamaha - New carb w/ low power and no reverse

Boy after you got that cart cleaned up it looks G00D
Cvans is offline   Reply With Quote
Old 08-08-2015, 01:09 PM   #4
GasYammiWannaRun
Not Yet Wild
Yamaha
 
Join Date: Jun 2015
Posts: 29
Default Re: '79 G1 Yamaha - New carb w/ low power and no reverse

Quote:
Originally Posted by Cvans View Post
Boy after you got that cart cleaned up it looks G00D
Yes, it does! Good job.
GasYammiWannaRun is offline   Reply With Quote
Reply

Tags
caburator, g1., power loss, reverse
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Full power in reverse, part power in forward Electric EZGO
2005 Precedent starts of powered, then loses power, reverse always power Electric Club Car
Yamaha The Drive carb power build up Gas Yamaha
Power in Reverse/Little Power in Forward Gas Harley Davidson
G2 Carb problem lacking power Gas Yamaha


All times are GMT -5. The time now is 04:36 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.