lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-30-2013, 03:07 PM   #1
chopperspares
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Titan XD not charging.

I recently picked up a Titan XD from another branch of our company to use
here at the shop. When I got it the charge would show full on the gauge but I would go not go more than 100 yards and stop. I tried charging several times and still had the same problem. With no maint records on the batteries I went ahead and replaced them.
With the new batteries installed the cart had plenty of power but now the meter was showing 1 flashing bar. I charged for a good 8 hours and still the same problem. I've checked all connections and evertyhing looks good.
I haven't checked charging output and wanted to know what that output should be going to the leads. No meter today so i'm going check that in the morning.
Currently the meter on the charger is showing 6 amps and the meter in the
cart is still flashing 1 bar. The charger started at 25 and decreased while writing.
Anymore troubleshooting ideas ?

Tks,
chopperspares is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-30-2013, 05:27 PM   #2
yurtle
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: Titan XD not charging.

New batteries can take a long time to charge. If your charger is automatic, let it run until it turns off.

Go to here and read up on everything about battery care and maintenance.

http://www.cartsunlimited.net

Trojan's website also has some good info and videos.
yurtle is offline   Reply With Quote
Old 11-02-2013, 08:48 AM   #3
chopperspares
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Re: Titan XD not charging.

Thanks yurtle..Everything seems to be working. I'm going to try
and change the charging meter.
Good web site on the batteries. Very in depth.
chopperspares is offline   Reply With Quote
Old 11-02-2013, 10:07 PM   #4
yurtle
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: Titan XD not charging.

Hey, if ya can't "kill the messenger", I guess ya can't thank him either. I mean, fair's fair.
yurtle is offline   Reply With Quote
Old 11-03-2013, 07:29 PM   #5
Thatsme?
Gone Wild
E-Z-GO
 
Join Date: Aug 2013
Posts: 187
Default Re: Titan XD not charging.

DVM is your friend. Total pack voltage, individual battery voltages after charging and after 12 hour rest will get you more help from the other guys that know.
Thatsme? is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Titan 589 M/T tires Golf Carts and Parts
cushman titan Gas EZGO
Cushman Titan Electric EZGO
Need Cushman Titan Help Electric golf carts
Cushman Titan (1997) Electric golf carts


All times are GMT -5. The time now is 01:46 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.