lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-23-2017, 05:10 PM   #1
FormulaMatt
Not Yet Wild
 
Join Date: Apr 2016
Posts: 16
Default Battery Charge Indicator Issue

Hello all!! I am finally putting on my new body and my light/horn/turn signal kit. I also installed brand new T105 batteries. My cart is a 1990 DS. It has not ever had a charge indicator on it, so I decided to put on on while I do all this other work to it.

I have an issue though. My 3 prong digital indicator will not work when connected to the key switch the way the instruction indicate. I have it wired correctly, but the only way to get anything is to wire the #1 & #4 as constant hot and #2 negative.

I did some searching and found someone with my same issue (quoted his solution below). He found a solution and asked if it would be ok, but I didn't see any replies as to whether it would hurt anything or not or give an accurate reading. Any advice? Thanks!



Quote:
Originally Posted by ruger.john View Post
Man something freaky is going on with the cart.

Well I try to do what you said and it doesn't light up the LED. However, if I take the positive from the #1 battery to the #1 post, the #2 post to the blue wire on the key switch and ground #4, it works. It turns on and off with the key.

I'm just not sure if this will cause any damage? Any ideas? i don't mind it being this way as long as I won't fry anything. The cart still drives and moves and everything so maybe its ok. I just would like to be certain though.

Thanks for all the help :)
Attached Images
File Type: jpg IMG_3440.jpg (330.6 KB, 0 views)
File Type: jpg IMG_3441.jpg (297.7 KB, 0 views)
File Type: jpg IMG_3442.jpg (265.3 KB, 0 views)
File Type: jpg IMG_3443.jpg (254.2 KB, 0 views)
FormulaMatt is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-23-2017, 06:24 PM   #2
mrgolf
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,881
Default Re: Battery Charge Indicator Issue

Not sure about your cart, but some carts have a negative key switch.
mrgolf is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
36V battery charge indicator on 48 v cart ? Electric Club Car
Battery Charge Indicator Incorrect Electric Club Car
Installing a battery charge indicator Electric golf carts
Simple Battery Charge Indicator ? Electric Club Car
Battery Charge Indicator Electric Club Car


All times are GMT -5. The time now is 12:48 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.