lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-28-2020, 02:17 PM   #1
mfinnegan
Gone Wild
 
mfinnegan's Avatar
E-Z-GO
 
Join Date: Mar 2020
Location: CT
Posts: 320
Default Total charge 3 possible issue..

Ran the cart a bunch testing out the new motor I got..the pack voltage ran down to 36.2V. Plugged it in the charger and it kicked on to 15AMP and was humming along. Pack voltage climbed to 42V in about 3 mins and then the charger just clicked off...while still plugged in it dropped down to 36.6V in about 10 minutes and won't turn back on.... I unplugged it from the cart and plugged it back in, but it's the same cycle only way, faster shutting off in 10 seconds and dropping to 36.6V in a minute....charger problem?

Edit: quick dumb video https://www.youtube.com/watch?v=vnbVJlOkU5w
mfinnegan is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Total Charge ll I.D. Electric EZGO
Total Charge Issue Electric EZGO
Total charge III 3 control board issue Electric EZGO
EZ-GO Total Charge 2 Electric EZGO
Total Charge 3 Golf Carts and Parts


All times are GMT -5. The time now is 04:44 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.