lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-15-2007, 08:56 AM   #1
preachermon
Not Yet Wild
 
Join Date: Sep 2007
Posts: 1
Default EZGO 36 volt probs...HELP!!

Hi,
I have a 1994 (I think) EZGO 36 volt electric
Recently started to make rattling sounds, then yesterday rattling became very loud and now when I drive it, it moves about 20 feet and then it seems to disengage and will not move. When I press the accelerator it sounds as if someting disengages. I can hear the motor spin but no forward and no reverse, unless I put the cart in neutral and push it about 3 feet, then I hear something click and then can make it engage again, but 20 feet later same prob.
Hope someone here might be able to point me in the right direction.
Thanks for your help in advance,
Preachermon
preachermon is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-15-2007, 01:51 PM   #2
roady89
nimda
Club Car
 
Join Date: Jun 2007
Posts: 13,023
Default Re: EZGO 36 volt probs...HELP!!

First...It doesn't matter if you place the cart in neutral....at least not on an electric cart. Second, sounds like you have a major differential problem. Its not going to be an "easy" fix if it is. Ezgo's are also bad about stripping the splines on the wheel hubs. Place the cart on jackstands and pull the wheels off and try to spin the axles to pinpoint where the noise is coming from.
roady89 is offline   Reply With Quote
Old 09-15-2007, 02:26 PM   #3
tungpo1
Gone Wild
 
tungpo1's Avatar
E-Z-GO
 
Join Date: Dec 2006
Location: St. Johns /Jacksonville
Posts: 2,383
Default Re: EZGO 36 volt probs...HELP!!

Good catch Roady I've spun a few out myself!!!
tungpo1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 03:11 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.