lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-06-2009, 07:58 PM   #1
captcbw
Not Yet Wild
 
Join Date: Jul 2009
Posts: 2
Default Club Car gas speed issues

I think it is a 1996 Club car, gas (forgot to check what engine)
Problem #1 started about 6 months ago. When you press the accelerator, to start, theres a whinning noise and then it starts. It does it everytime.

Problem #2 started today, The engine only has fast speed, it wont go slow. I have removed the top from the throttle control box and cleaned the switch and linkage. Still same thing

Thanks for a reply
captcbw is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-06-2009, 08:15 PM   #2
lockman1
What the ....?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 13,765
Default Re: Club Car gas speed issues

Welcome to BGW!

Your engine is most likley an FE290

#1 your starter belt is loose, or worn causing the whinning

#2 remove your carburetor and check to see if your "Butterfly" (throttle plate) came off... it's not all that uncommon!
(maybe if your lucky, it didn't get sucked into your engine yet!)

lockman1 is offline   Reply With Quote
Old 07-06-2009, 08:17 PM   #3
captcbw
Not Yet Wild
 
Join Date: Jul 2009
Posts: 2
Default Re: Club Car gas speed issues

Quote:
Originally Posted by lockman1 View Post
Welcome to BGW!

Your engine is most likley an FE290

#1 your starter belt is loose, or worn causing the whinning

#2 remove your carburetor and check to see if your "Butterfly" (throttle plate) came off... it's not all that uncommon!
(maybe if your lucky, it didn't get sucked into your engine yet!)

Thanks, Ill check it out
captcbw is offline   Reply With Quote
Old 07-07-2009, 12:56 PM   #4
WalleyeO
Not Yet Wild
 
Join Date: Jun 2009
Posts: 5
Default Re: Club Car gas speed issues

Chaeck Carb Butterfly valve is half or all gone.
WalleyeO is offline   Reply With Quote
Old 07-07-2009, 09:57 PM   #5
lockman1
What the ....?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 13,765
Default Re: Club Car gas speed issues

Yeeaahhh... I said that already... but, thanks for the back up Walleye!
Hopefully the Captain will get back to us, and let us know what happened!

lockman1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car Charging issues Electric Club Car
92 Gas Club Car Starter issues Gas Club Car
92 Club Car More Speed Gas Club Car
99 club car (gas) not getting up to speed Gas Club Car
Speed Issues with Electric Club Car Electric Club Car


All times are GMT -5. The time now is 08:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.