lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-14-2017, 11:44 AM   #1
toxicwaste29
Gone Wild
Yamaha
 
Join Date: Aug 2014
Location: Ohio
Posts: 176
Default MCI engine noise

I am working on a ezgo mci engine that has a loud bearing sounding noise. I went through and replaced the idler since it was bad along with all the bearings in the crankcase except the two in the crankcase cover since they are in an odd position. I checked them and they seemed fine with no skipping or grooves. It starts out light and increases as the engine speeds up with the drive belt disconnected. I also disconnected the starter belt and its not in the starter.

Any ideas would it could be?
toxicwaste29 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-14-2017, 05:18 PM   #2
googl1
Not Yet Wild
 
Join Date: Jun 2013
Posts: 24
Default Re: MCI engine noise

I am not trying to insult you in any way. I do not know you, or your abilities, so I have to start basic. Please bear with me. I can help.

It would really help if you would post a video of the engine and sound. You may have to use Youtube.

What makes you think it is a ball bearing?
Are you re-using bearings? How did you inspect them? How did you clean them?

Other possibilities:
Piston slap
rod bearing slap
balancer not timed correctly (did the engine seize up ever?)


The list goes on, but above are common problems we get.
googl1 is offline   Reply With Quote
Old 08-17-2017, 10:39 AM   #3
toxicwaste29
Gone Wild
Yamaha
 
Join Date: Aug 2014
Location: Ohio
Posts: 176
Default Re: MCI engine noise

https://www.youtube.com/watch?v=ILXFzYT05H0
toxicwaste29 is offline   Reply With Quote
Old 08-20-2017, 07:33 PM   #4
toxicwaste29
Gone Wild
Yamaha
 
Join Date: Aug 2014
Location: Ohio
Posts: 176
Default Re: MCI engine noise

I got the video posted up. ^
toxicwaste29 is offline   Reply With Quote
Old 08-20-2017, 07:45 PM   #5
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,061
Default Re: MCI engine noise

I'm not hearing it.
cart around is online now   Reply With Quote
Old 08-21-2017, 11:13 AM   #6
toxicwaste29
Gone Wild
Yamaha
 
Join Date: Aug 2014
Location: Ohio
Posts: 176
Default Re: MCI engine noise

its the high pitched noise that sounds like a belt whine.
toxicwaste29 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO RXV gas engine noise Gas EZGO
95 Club car engine noise! Gas Club Car
Robin engine noise Gas EZGO
G16 engine noise Gas Yamaha
Engine noise Gas EZGO


All times are GMT -5. The time now is 05:08 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.