lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Columbia ParCar


Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-10-2024, 09:39 PM   #11
raydhd
VC 460 CLONE GONE WILD
 
raydhd's Avatar
Yamaha
 
Join Date: Oct 2014
Location: Ray BY The Bay NJ
Posts: 10,791
Default Re: 1989 Par Car - Starts but doesn't run good

I wonder IF the muffler was blocked and loaded up the crankcase ? I see 2 options here. 1 Run it with no muffler. 2 Just go ahead and pull the cylinder off. It is really no that hard to do leaving the engine still mounted in the chassis. You do it a couple of times and you get real good at it. A lot depends on the compression test.
raydhd is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-11-2024, 10:50 AM   #12
buddsy92
Not Yet Wild
 
Join Date: May 2024
Posts: 32
Default Re: 1989 Par Car - Starts but doesn't run good

Update:

Compression test was 110 so itís a bit low but should have plenty of power.

I wanted to look at fuel issues so I removed the hose from the gas tank and held it upright so that I could run the lines dry.

Oddly enough - as the fuel level dropped it started to run better and better and then the last 5-10 seconds it was absolutely howling until it ran out of gas.

So Iím guessing that this is an issue with the carb supplying too much fuel?

Suppose it could be the pump as well but it looks to be working
buddsy92 is offline   Reply With Quote
Old 05-12-2024, 01:09 PM   #13
Leon willis
Gone Wild
 
Leon willis's Avatar
E-Z-GO
 
Join Date: Mar 2022
Location: Ohio
Posts: 475
Default Re: 1989 Par Car - Starts but doesn't run good

Yeah your fuel pump is junk itís not pumping enough fuel
Leon willis is offline   Reply With Quote
Old 05-12-2024, 08:48 PM   #14
buddsy92
Not Yet Wild
 
Join Date: May 2024
Posts: 32
Default Re: 1989 Par Car - Starts but doesn't run good

Quote:
Originally Posted by Leon willis View Post
Yeah your fuel pump is junk itís not pumping enough fuel
It seems like itís getting too much fuel, no?

If I remove the hose from the fuel tank, Iíd assume the bowl is slowly draining and the A/F ratio is leaning out and making it run better.

Does that make sense?

When I drain the line and hook it all back up, the cart runs amazing for like 7 seconds then starts bogging. Presumably because itís getting to much fuel?
buddsy92 is offline   Reply With Quote
Old 05-13-2024, 03:12 PM   #15
Lochlin
Gone Wild
 
Join Date: May 2011
Location: Pittsburgh
Posts: 2,972
Default Re: 1989 Par Car - Starts but doesn't run good

These are low compression engines so 110 psi is actually very good. Heck, anything over 90 should be ok and 120 just about never happens on these carts.

Being that the motor was chugging for a few seconds means that your timing is good too.

Really, it seems like your carb is fudged up somewhere. Try adjusting the float in the bowl some so that the needle closes some. There are lot of you tube videos about how to adjust a carb's float.

If nothing else, you can always get a new carb and I would bet that takes care of things.
Lochlin is offline   Reply With Quote
Old 05-13-2024, 04:32 PM   #16
buddsy92
Not Yet Wild
 
Join Date: May 2024
Posts: 32
Default Re: 1989 Par Car - Starts but doesn't run good

Quote:
Originally Posted by Lochlin View Post
These are low compression engines so 110 psi is actually very good. Heck, anything over 90 should be ok and 120 just about never happens on these carts.

Being that the motor was chugging for a few seconds means that your timing is good too.

Really, it seems like your carb is fudged up somewhere. Try adjusting the float in the bowl some so that the needle closes some. There are lot of you tube videos about how to adjust a carb's float.

If nothing else, you can always get a new carb and I would bet that takes care of things.

Thanks, Loch. I've messed with this carb a few times already, cleaned the snot out of it and adjusted the float to close quicker, etc. Doesn't seem to be any improvements.

I ordered the 82-87 EZGO you mentioned but I must be missing something on how to set it up because my stock carb "springs open" when the accelerator is pressed, and then snaps shut when releasing the accelerator. In other words, when no forces are applied this throttle plate is open. Only when force is applied does the throttle plate close (releasing gas pedal)

This one that arrived today is backwards, I think. Where it springs closed, and needs to be pulled open with the accelerator cable.

Does that make sense? Did I order the wrong carb?
buddsy92 is offline   Reply With Quote
Old 05-13-2024, 05:02 PM   #17
buddsy92
Not Yet Wild
 
Join Date: May 2024
Posts: 32
Default Re: 1989 Par Car - Starts but doesn't run good

is this the correct one to fit my 1989? https://www.vintagegolfcartparts.com/Item/EZ_Carb88
buddsy92 is offline   Reply With Quote
Old 05-16-2024, 05:45 PM   #18
buddsy92
Not Yet Wild
 
Join Date: May 2024
Posts: 32
Default Re: 1989 Par Car - Starts but doesn't run good

Turns out it was a bad fuel pump (original one from 35 years ago)

I swapped to an electric pump, Mr Gasket 42S, for $95 and it runs like a dream!!

Thereís a thread on here on how to hook it up. Super simply and what an improvement it made wow.
Attached Images
File Type: jpg IMG_2077.jpg (257.8 KB, 0 views)
buddsy92 is offline   Reply With Quote
Old 05-16-2024, 05:48 PM   #19
raydhd
VC 460 CLONE GONE WILD
 
raydhd's Avatar
Yamaha
 
Join Date: Oct 2014
Location: Ray BY The Bay NJ
Posts: 10,791
Default Re: 1989 Par Car - Starts but doesn't run good

That looks like a copy of the Holley Mighty Mite 12-426. That is still on 1982 HD /sled engine cart. I am one of the pro electric fuel pump members.
raydhd is offline   Reply With Quote
Old 05-16-2024, 06:27 PM   #20
buddsy92
Not Yet Wild
 
Join Date: May 2024
Posts: 32
Default Re: 1989 Par Car - Starts but doesn't run good

Quote:
Originally Posted by raydhd View Post
That looks like a copy of the Holley Mighty Mite 12-426. That is still on 1982 HD /sled engine cart. I am one of the pro electric fuel pump members.
Iím certainly a believer now. Wow it runs so strong and gets up and goes almost instantly now. Sheís got lots of pep!!
buddsy92 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Columbia ParCar


Thread Tools
Display Modes


Similar Threads
Thread Forum
2000 G16A doesn't run but starter motor starts Gas Yamaha
88 Marathon starts, runs but doesn't rev up Gas EZGO
Starts,but doesn't start? Gas EZGO
86 ezgo starts but doesn't always go Gas EZGO
Help! My Yama G16A starts but doesn't charge? Gas Yamaha


All times are GMT -5. The time now is 03:50 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.