lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha
Electric Yamaha Electric Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-07-2020, 05:32 PM   #1
Jasonrkba
Not Yet Wild
Yamaha
 
Join Date: Sep 2019
Location: NC.
Posts: 19
Default G2 no power

I have an old G2. The solinoid went bad so I replaced it. I get a very solid click when I hit the pedal but nearly no voltage at the controller or the solinoid pole going to it. Im handy but not a pro. Any suggestions would be appreciated.

Thanks. Jason.
Jasonrkba is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-08-2020, 12:52 PM   #2
slonomo
Seaching for "The Way"
 
slonomo's Avatar
Yamaha
 
Join Date: Oct 2009
Location: Medina, Ohio (NEOHIO)
Posts: 9,092
Default Re: G2 no power

Did you check your batteries voltage? What's the age of the batteries.
slonomo is offline   Reply With Quote
Old 11-15-2020, 12:43 AM   #3
Jasonrkba
Not Yet Wild
Yamaha
 
Join Date: Sep 2019
Location: NC.
Posts: 19
Default Re: G2 no power

Sorry to get back so late. The new solinoid was shot, i had bought a chepo. I replaced it with a better one and it runs great but when i stop the solinoid stays energized even wth the key out. The batteries where all replaced less than a year ago with US 2200. If I remove the power wire from the solenoid it releases. I hook everything back up and its fine until I stop. Then it sticks again.
Jasonrkba is offline   Reply With Quote
Old 11-19-2020, 12:59 AM   #4
Jasonrkba
Not Yet Wild
Yamaha
 
Join Date: Sep 2019
Location: NC.
Posts: 19
Default Re: G2 no power

Anyone?
Jasonrkba is offline   Reply With Quote
Old 11-19-2020, 01:34 AM   #5
Jasonrkba
Not Yet Wild
Yamaha
 
Join Date: Sep 2019
Location: NC.
Posts: 19
Default Re: G2 no power

Could a bad resistor coil cause this problem?
Jasonrkba is offline   Reply With Quote
Old 11-19-2020, 03:59 AM   #6
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 16,980
Default Re: G2 no power

Wait, controller? G2 had no "controller", it was a "resistor coil" cart. We first need to know for sure what where dealing with.
cgtech is offline   Reply With Quote
Old 11-19-2020, 06:37 PM   #7
Jasonrkba
Not Yet Wild
Yamaha
 
Join Date: Sep 2019
Location: NC.
Posts: 19
Default Re: G2 no power

Forward reverse switch. Sorry I thought that is what it is called.
Jasonrkba is offline   Reply With Quote
Old 11-21-2020, 01:14 PM   #8
Jasonrkba
Not Yet Wild
Yamaha
 
Join Date: Sep 2019
Location: NC.
Posts: 19
Default Re: G2 no power

With the negative terminal disconnected, key removed. I checked voltage at the solinoid and have 36 volts at the large positive and two small posts. I have half that at the large post that goes to the frwd-rvs switch. Something is off. The new solinoid seems stuck now.. I have studied the wiring diagram until my eyes are crossed and everything looks correct. Is there something in the motor that would send a constant voltage?
Jasonrkba is offline   Reply With Quote
Old 11-22-2020, 12:46 AM   #9
Jasonrkba
Not Yet Wild
Yamaha
 
Join Date: Sep 2019
Location: NC.
Posts: 19
Default Re: G2 no power

Well for anyone who has read this. I took the new solinoid apart and the small wire that connects to the terminal had broken off. I resolderd it, replaced a couple connections and changed the way the solinoid mounted by drilling new holes just to make it easier to work on and now it works fine.
Jasonrkba is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
1995 ezgo medalist power, new batteries, no power to the solenoid Electric EZGO
Full power in reverse, part power in forward Electric EZGO
2005 Precedent starts of powered, then loses power, reverse always power Electric Club Car
Power Wise Charger worked after board replaced now back to no power Electric EZGO
have power on ezgo buggy no power light Electric EZGO


All times are GMT -5. The time now is 12:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.