lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-04-2022, 09:16 PM   #1
Rob_C
Getting Wild
Mixed Breed
 
Join Date: Dec 2017
Location: Richmond, NSW Australia
Posts: 115
Default '04 DS Charge Issue

Just looking for someone to confirm my thoughts.

'04 DS as mentioned, plug the charger in, it clicks but no real ammeter movement.

Pack voltage 47V

53V across the charge socket at the + and - terminals with it plugged in.

Shorted the black socket wire to the pack negative and the charger jumps to 15A.

Checked all leads solidly connected to the charge socket.

Cleaned all leads and terminals, replaced the terminal on the red charge lead.

Checked the continuity of all cables and the earth of the black charge wire at the controller.

I'm assuming OBC death but would like someone with more experience to confirm if possible or let me know if I have missed anything.

Thanks in advance,
Rob
Rob_C is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
E.R.I.C charge issue Electric Club Car
Total charge 3 possible issue.. Electric EZGO
No charge issue Electric EZGO
36 Volt DCS TXT Charge Issue?? Electric EZGO
Charge issue Electric Club Car


All times are GMT -5. The time now is 12:14 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.