Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Gas Melex (https://www.buggiesgonewild.com/forumdisplay.php?f=83)
-   -   Melex 512 Not moving (https://www.buggiesgonewild.com/showthread.php?t=79923)

dan1508 05-09-2013 08:06 AM

Melex 512 Not moving
 
I have a Melex 512 that when we put it away in the fall it moved fine. Now that it's warmed up I've tried to run it and when I step on the gas the motor runs, but it doesn't engage and move.

I know in previous years we've sat for a few while it warmed up and moved, but I did that for over 20 minutes and nothing.

Is there something else I should be looking for and checking or does it just need some more warm up time? any help is very appreciated.

dan1508 05-16-2013 10:38 PM

Re: Melex 512 Not moving
 
Anyone have any ideas? Am I giving enough info?

BumbleBee 05-23-2013 01:11 PM

Re: Melex 512 Not moving
 
It sounds like the clutch is stuck and not engaging. have you checked it out? if the I am no expert on those clutches but if it's not moving, it sounds like the thing is froze and not moving to engage. you could shoot the backside with a penetrate and see if it will free up. PB Blaster is good for stuff like this.

hope that helps. I hope someone comes along with better info then me to help you. if you don't get a response here you my want to try and post it in one of the modified forums and see what happens.

good luck

Arin


All times are GMT -5. The time now is 01:59 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.